Jump to content


Photo

LG LCD monitor Incompatible with Suse 9.1 text mode?


  • Please log in to reply
8 replies to this topic

#1 Idea

Idea

    stranger

  • Members
  • 5 posts

Posted 11 November 2004 - 04:10 AM

I have a new LG L1716S LCD monitor. It works good with Windows, Dos, KDE mode of Suse 9.1 and GRUB. But it can't be used in text mode of Suse 9.1, even in installation too. Warning "In put signal out of Range" appearances on the Screen. Hat someone a solution?

#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 11 November 2004 - 12:52 PM

Let me just clarify...

You have an install of SuSe 9.1 and added a new monitor since the initial install?

You are able to boot into SuSe and get your KDE screen right off, or do you get a text screen at boot? If this is the case, you need to change the monitor frequencies for the X windows system to match the new monitor, as X is using the old settings from the old monitor.

When you boot into Windows, everything is still fine?



#3 Idea

Idea

    stranger

  • Members
  • 5 posts

Posted 11 November 2004 - 04:20 PM

I have already SuSe 9.1 on my computer, and the new LCD can be used in KDE, but it can't be used in text mode. I have even no screen at boot. I tried to reinstall SuSe, but i find that, it can't be used in install too! Wenn i boot into Windows, is everything OK.

#4 Idea

Idea

    stranger

  • Members
  • 5 posts

Posted 11 November 2004 - 04:27 PM

What can i do except another monitor to buy?

#5 egorgry

egorgry

    enthusiast

  • Members
  • 315 posts

Posted 11 November 2004 - 04:38 PM

interesting problem ya got Idea. I don't know much about how suse boots but is it graphical or text? If it's text does it look ok until you get teh login manager then switch back to a console?
From X (can be at the login screen) type ctrl alt F1, what do you get?

#6 Idea

Idea

    stranger

  • Members
  • 5 posts

Posted 11 November 2004 - 05:56 PM

SuSe boots with text on a image backgrund, the same way of Gentoo, it can't be showed on my LCD. With ctrl alt F1 hat the same problem, also, text mode of Linux can not be showed, even in installation too.

#7 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 11 November 2004 - 08:02 PM

I think that I know the problem.

On install, you need to tell SuSe to install at 1024 X 768. There is a tab to F3 or something on the bottom of the initial install window to do this.

In terms of you existing installation, if you have KDE up, then you need to go into the Control Panel and set up the new monitor. I will look at this later. I bet your monitor is not shown there, so you may need to have the correct settings from the users manual. It should be generic (vesa) LCD. Look at the manual and get the correct horizontal and vertical sync ranges. It should be something like;

Horizontal = 30-83
Vertical = 56-75

You need to run it at probably;

1280 X 1024 @ 60 hz or;

1024 X 768 @ 75 hz

But use your monitor specific ranges.

You really need to do this to assure that the ranges are corect, or risk possible damage to the monitor.

#8 Idea

Idea

    stranger

  • Members
  • 5 posts

Posted 11 November 2004 - 11:49 PM

I got the solution: set in /boot/grub/menu.lst the value vga = normal. This value is for the output signal setting of text mode.
Normal means the standard VGA input, which 720 * 400 @ 70 is.More Information find man in svga.txt.

#9 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 12 November 2004 - 02:47 AM

That wa my second idea (pun intended). I should have posted that first! Good going!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq