Jump to content


Photo

Monitor conifguration problems


  • Please log in to reply
4 replies to this topic

#1 redrobbo2004

redrobbo2004

    stranger

  • Members
  • 2 posts

Posted 08 November 2004 - 08:18 PM

I am going through the pain of my first Linux install. I am trying to install Mandrake 10.1 on my old Dell Optiplex, in conjunction with 2 even older monitors. The install has worked so far in that I can boot to a text prompt. The problem is that I cannot get to the GUI interface (KDE or Gnome). The boot sequence progresses without error and then the screen simply goes blank. Booting in failsafe mode and then running drakconf gives me the option of changing my display config. The Optiplex has a intel 810 chipset, which I guess is OK. Is the problem with my monitors? I have tried 2, a Gateway CrystalScan 17" monitor and an even older ProVision 14" one. I cannot find either of them from the list of vendor monitors. I have tried any number of options, but they all fail when tested.

Any advice?

#2 SoulNothing

SoulNothing

    enthusiast

  • Members
  • 309 posts

Posted 08 November 2004 - 09:29 PM

all right your going to have to do this manually entering the numbers im not sure bout the monitors but heres my recommendations start with the older 14 inch and then go from there it should be in the database
1st could you be more specific on the monitor names like if you see any sort of number how i tell mine is if the machine came with a driver disc theres usually one for the monitor and it will list the number or on the back of the monitor
all right size really doesnt matter but the anges do
last bit of info is could you please list the max resolution i find this to help
all right im not sure if mandrake will let you do this but once you have the blank screen hit ctrl+alt+(f1-f8 i beleive)
login now type
xf86config or i beleive XF86Config i forget which and (cases matter)
now go through it, it should ask about mouse keyboard and graphics card
for the resolution i recommend starting small
im not sure really but as stated dont over do it if you do that might mess up the monitor
then once done reboot if that doesnt work
someone here should know how to kill x and go to a virtual by terminal by ctrl+alt+F(X)
so kill x unsure the command for mandrake and then once killed x type start x record what you see and post that it may not be just the monitor

#3 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 08 November 2004 - 09:46 PM

Even Windows doesn't store drivers for every monitor configuration.

Does Mandrake still use XFdrake in 10.1? From the command line as root go:

XFdrake [enter]

And see if the Mandrake configuration tool comes up. If it does, go into the monitor section and try a monitor that is as close to yours. Sometimes this works or at least gives you something to look at as a starting point.

In such cases you may need to configure your monitor "by hand." which is not quite as difficult as it may sound. Do you have the manual on either of these monitors? If not, find out the vertical and horizontal rates on them so we can edit the necessary configuration files.

By the way, what vid card are you using?

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 09 November 2004 - 04:24 AM

Dell Optiplex? What speed processor is in it and how much memory? Is this a GXA, GX1...?

#5 redrobbo2004

redrobbo2004

    stranger

  • Members
  • 2 posts

Posted 09 November 2004 - 12:27 PM

Hi Guys,

Thanks for all your responses. Through a combination of your suggestions and a bit of good old trial and error my monitor is now working properly.

Just in case anyone else has a similar problem....

Mandrake 10.1 has a utility drakconf in which you can set any number of config issues (no need to edit the XF86config thingy)

1. Set the monitor to the lowest resolution and colour
2. Set the graphical display to VESA (even though my intel 810 chipset was in the list of vendors)
3. Play around with the refresh rates. !!! You should really RTFM regarding the max rates as you can apparently damage your monitor. In my case, I didn't have the manual and the monitor is so old I figured it was worth the risk.

I think No.2 was the main contributor. This resulted in a successful boot to the GUI. From there, I was able to alter the settings through the CUI Mandrake Configurator.

Thanks again for all your help.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq