Jump to content
Compatible Support Forums
Sign in to follow this  
Admiral LSD

Trying to compile PHP 4.2.2 under Red Hat 7.2...

Recommended Posts

and not getting very far. It bombs out with the following error every time:


make[3]: *** [php_functions.lo] Error 1make[3]: Leaving directory `/tmp/php-4.2.2/sapi/apache2filter'make[2]: *** [all-recursive] Error 1make[2]: Leaving directory `/tmp/php-4.2.2/sapi/apache2filter'make[1]: *** [all-recursive] Error 1make[1]: Leaving directory `/tmp/php-4.2.2/sapi'make: *** [all-recursive] Error 1


Any idea what I could be doing wrong?

Share this post

Link to post
Share on other sites

*slaps self*


had LSD been paying attention he would have noticed the fix was just a few rolls of the scroll wheel away...


Edit the file sapi/apache2filter/php_functions.c and jump down to line 93.

You'll see a bit that looks like this:


#if !MODULE_MAGIC_AT_LEAST(20020506,0)




Change the "MODULE_MAGIC_AT_LEAST" bit to read

"AP_MODULE_MAGIC_AT_LEAST". The former is deprecated and

expands to "this macro shouldn't be used" or something like



It's possible that there are other places where this needs to change, too.


After having done that and watching as it compiled without incident I then proceeded to perform a make install whereby it told me something about an "error recursive." Fixing that was simple too: you have to run the make install with the -i (ignore) parameter. Now that it seems to be installed properly, time to set about testing it icon6.gif

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this