Jump to content


Photo

how to config the sound card in the mandrake 10.0


  • Please log in to reply
4 replies to this topic

#1 oliveirinhasus

oliveirinhasus

    stranger

  • Members
  • 2 posts

Posted 05 October 2004 - 11:04 PM

I have a HP pavillion 3340 and i installed the linux mandrake 10.0 in my computer. Its all fine with exception of the sound system that doesnt work. When the computer boot the mute section activate and i cant hear nothing, cds, programs, games, nothing! Thanks for your attention. Best regards
Hugo Oliveira

#2 SoulNothing

SoulNothing

    enthusiast

  • Members
  • 309 posts

Posted 06 October 2004 - 01:33 AM

all right first could you please tell us what your sound card is onboard if so mobo type etc.

secondly when i used mandrake 10.0 official and community i had the same problem on my computer no sound for anything, cds i never cracked that one for any version

but heres what i did mandrake has kde set as the default desktop manager um i just switched to gnome and i had sound went back to kde no sound i dont know why so try that if that doesnt help which i doubt it will post your card and we can go from there

#3 CrazyKillerMan

CrazyKillerMan

    old hand

  • Members
  • 761 posts

Posted 06 October 2004 - 07:37 PM

I had the same issue with my Audigy. Everything was set up correctly (kernel) and alsa and its tools were working. After I played around I found that the digital outputs were enabled.

If the soundcard has digital output, ensure that this option is disabled.

#4 oliveirinhasus

oliveirinhasus

    stranger

  • Members
  • 2 posts

Posted 09 October 2004 - 12:59 PM

Ok, i will switch to gnomo. Thank you. Best regards,
Hugo Oliveira

#5 egorgry

egorgry

    enthusiast

  • Members
  • 315 posts

Posted 09 October 2004 - 05:07 PM

Do you get sound when you log in as root? if so it may be permissions this is a common problem on some distros.

Login to the desktop of your choice as root and try to play an MP3 if that works then you may need to add yourself to the audio group.

adduser yourname audio

to verify

groups yourname

you should see something like this..
[10/09/04][greg@otis:~]$ groups greg
greg : greg disk lp cdrom audio src video users

if that doesn't work then

cd /dev
ls -l dsp*

you should see that all things dsp are owned by root and group is audio.

something like this...
crw-rw---- 1 root audio 14, 3 Jun 30 12:17 /dev/dsp
crw-rw---- 1 root audio 14, 19 Jun 30 12:17 /dev/dsp1
crw-rw---- 1 root audio 14, 35 Jun 30 12:17 /dev/dsp2
crw-rw---- 1 root audio 14, 51 Jun 30 12:17 /dev/dsp3

if not then do this
chgrp audio dsp*
chmod 660 dsp*

that should do it assuming it's a permissions issue wink

Good luck and don't leave us hanging. It's nice to see resolved issues.






[Edited by egorgry on 2004-10-09 11:12:14]





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq