Jump to content
Compatible Support Forums
Sign in to follow this  
DanJo

Redhat 9 installation

Recommended Posts

Hi,

 

I am unfortunately running XP and wish to create a dual boot system with RH 9. I've downloaded the Shrike ISO's and burn't them to CD however, during the install process the installation program asks for the Redhat CD?

 

Is there a Step by Step "idiots guide" for installing Redhat which covers all the steps that need to be done, including what needs to be partitioned and how?

 

Maybe I'm too far gone to be rescued from the MS syndrome?

 

Help me please....

Share this post


Link to post
Share on other sites

DanJo welcome!

 

You're just the kind of person that we like to help!

 

First, when you say it asks for the RH install disk, does that mean you made a boot floppy to get the process started with? If booting from the CDs, is it possible you mislabled the disks and might have put disk 2 or 3 in instead of disk 1?

 

Which burning program did you use? At what speed did you burn it? Did you check the file size of the ISOs using md5sum check?

 

If you don't know the answer to some of these, just say so and I'll explain further...

Share this post


Link to post
Share on other sites

Thanks for the quick response...

 

I downloaded three Shrike ISO's from linux.org? and burnt them directly to CD using Nero 6.3 @ 4x. I did the MD5SUM check and also checked the media via the option in the install program.

 

I think that one problem is maybe due to the fact that I was a little enthusiastic and have not read all the gumf beore going ahead with the installation attempt. I have since read that NTFS format is not preffered and that I need two partitions available for Linux.. I have made only two partitions (in NTFS format), one with XP on and the other was to be for Redhat...so this needs to be changed?

 

I have also read that it maybe better to use the DOSUTILS to burn the three CD's and a seperate boot CD?

 

Any advice with the correct approach would be sincerely appreciated..

 

I have a DELL dimension 8000 (Pent IV-1.7Ghz)

2x60 GB HDD (both with two NTFS partions)

512mb RAM

Terratec EWS MT88 Sound Card with breakout box

DVD-RW

DVD-ROM

3.5 FDD

256 mb Graphics card

 

 

 

 

Share this post


Link to post
Share on other sites

OK, it makes sense now. It appears that you have done everything right as far as burning the ISOs go.

 

As far as I know, you cannot install Linux to an NTFS formatted partition. What program did you use to do this formatting? If Partition Magic, we can use it to our advantage.

 

You should format the partition you are installing Linux to as ext3. We can do this with a partitioning utility, like partition magic, or you can do it with the RedHat partitioning utility.

 

You have 2 hard drives each with 60 gig? Or one 120 drive with two partitions? If one, with two 60 gig partitions and 512 ram, I would just install a root partition, a swap and a home partition. Then after you're up and running, I'd disable the swap, (easy to do), since you really don't need it. Not having one will let your ram really go to work for you which will make your box faster. I have 512 ram too and don't use a swap. smile

 

Do you have a Windows partitioning program or will we need to do it with the one on the RH cd?

 

 

Share this post


Link to post
Share on other sites

Cooking with Gas!

 

Thanks for the advice but I was a little too impatient...I used a third HDD, formatted using PM and the install worked first time.I just need to check if everything is working as it should. I'll delete the swap file and start playing tonight.

 

What I have seen so far is very impressive and fast. Hopefully within a few days, it's gonna be bye bye Billy!

 

Thanks for the support, and I'll let you know how I get on..

 

Groetjes van Belgie....

 

Share this post


Link to post
Share on other sites

Don't delete that swap partition, unless you are certain you won't be needing it. All you have to do is comment it out in /etc/fstab. I would keep it as it won't hurt anything to have it around,

 

To edit your /etc/fstab, become root:

 

su [enter]

 

then:

 

gedit /etc/fstab [enter]

 

where you see the line pertaining to the swap, just put a "#" in front of it. Here's mine to give you an idea...

 

 

Code:
/dev/hda5            /                    reiserfs   acl,user_xattr        1 1/dev/hda1            /boot                ext3       user,acl              0 0/dev/hda7            /home                reiserfs   acl,user_xattr        1 2# /dev/hda6            swap                 swap       pri=42                0 0devpts               /dev/pts             devpts     mode=0620,gid=5       0 0proc                 /proc                proc       defaults              0 0usbfs                /proc/bus/usb        usbfs      noauto                0 0sysfs                /sys                 sysfs      noauto                0 0/dev/cdrecorder      /media/cdrecorder    subfs      fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0/dev/dvd             /media/dvd           subfs      fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0/dev/fd0             /media/floppy        subfs      fs=floppyfss,procuid,nodev,nosuid,sync 0 0/dev/hda2            /mnt/hda2            ext3       user,acl              1 2/dev/hda3            /mnt/hda3            ext3       user,acl              1 2

Share this post


Link to post
Share on other sites

Hi It's me again,

 

I seem to have really "Phuked" things up now.... After doing a clean install on a borrowed HDD, things worked just fine with a few minor Sound Card and Linksys problems, I decided to go back and retry the dual boot scenario(which I had successfully done on a friends Dell Dimension). Yes I know - STUPID. If it works leave it alone...but I had to give back the borrowed HDD.

 

The original HDD was a dual boot Win 2000/XP on C and D respectively. I quite stupidly Partition Magic'd C into two EXT3 partions, rebooted the PC with a RH9 boot diskette and everything worked fine until it didn't recognise the CD's again..

 

I don't understand why with my installation that the CD's are not found when they do work on another almost identicle base system and worked on a clean HDD install? Could this be a bios problem. There doesn't seem to be any info from Dell.

 

The problem I now have is that I have two empty EXT3 Partitions followed by an NTFS partition with XP on which of course no longer boots smile......

 

I thought about doing an NFS install but couldn't remember my IP address and of course hadn't written it down. Can I stick in any address or is it possible to find it back?

 

Alternaively would it be possible to access the original ISO files on the NTFS partition? If so, how do I navigate to the file location.

 

I know, pretty lame, but lets say I'm just learning the hard way...

 

Share this post


Link to post
Share on other sites

Windows wants to be in the first part of your hard drive. If I were in your position, I'd download a copy of Knoppix, a live Linux OS that runs entirely from the cd, set your bios to boot cd before HD, and use Knoppix to mount and salvage your valuable XP files. Knoppix has a very intuitive and easy to use cd burner to burn those files with called K3B. Knoppix/K3B shouldn't have any trouble finding your CD burner.

 

Once you've completed the salvage operation, I'd nuke and pave the hard drive, install XP, install Partition Magic. Do a thorough defrag on XP, then use PM to reduce your XP partition, and create an empty space on the last part of your HD for RH9.

 

In that empty space, create a /boot partition. around 100 MB or so, a / partition, a swap partition 3 times the size of your RAM, and a /home partition. Format /boot, /, and /home with EXT3 file system.

 

When this is completed, it should be a simple matter to install RH9 to those partitions. Be sure to chose to manually partition hard drive, and just asign your Linux partitions accordingly. You will not have to actually do any partitioning.

 

RH will install Grub as the default boot loader which will allow you to navigate between XP and RH9 with ease.

 

I hope this helps...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×