Jump to content
Compatible Support Forums
Sign in to follow this  
xenon

FTP to SuSE 9.0 LiveEval (Booted)

Recommended Posts

I am working a subnet where I am trying to FTP to a

SuSE 9.0 LiveEval (bootable linux). I am begining

to think I should just as well go out an pick four

leaf clovers! Here is what I have done thus far...

 

I INSTALLED AN FTP DAEMON...

 

> cd /tmp

> rpm -i -vv -force -root /windows/c/temp vsftpd-1.2.0-52.i586.rpm

> cd /usr

> mv local local.orig

> ln -s local /windows/c/temp

> mv sbin /windows/c/temp

> cd /var/log

> touch vsftpd.log

> chmod 777 !$

> cd /etc

> vi vsftpd.conf

--anonymous-enable=YES

--local_enable=YES

--write_enable=YES

--local_umask=022

--listen=YES

--anon_upload_enable=YES

--anon_mkdir_write=YES

--connect_from_port_20=YES

--secure_chroot_dir=/windows/c/temp/jail

----(also tried /tmp)

> cd /usr/local

> vsftpd &

...muns

 

SEND THE FTP

> ftp -a

FTP> open HOST0

...I get the banner I set in the vsftpd.conf

FTP> verbose on

FTP> binary

FTP> cd /tmp

...Failed to change diretory

FTP> cd /windows

...Failed to change directory

FTP> put random.dat

...Could not create file

 

 

What gives? Is this even possible?

Please enlighten me to the tao of

SuSE ftp! smile

Share this post


Link to post
Share on other sites

Solution:

 

Found that I had to do the following to get

FTP to work:

 

1. vi /etc/passwd

insure that user "ftp" had a home directory

that was in writable user space, say /home/ftp.

 

2. In the /home/ftp directory, made a subdir

called "incoming" (can't do a root ftp put

in the FTP home, anonymously).

 

3. chmod/chown such that....

 

drwxr-xr-x ftp root incoming

 

4. QED, huh! Works now...finally.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×