Jump to content


Photo

Help! NOT a newbie: A7N8X-Deluxe - 3COM LAN NIC not working


  • Please log in to reply
1 reply to this topic

#1 Xaphod

Xaphod

    stranger

  • Members
  • 2 posts

Posted 29 January 2003 - 08:38 AM

I'm running the Asus A7N8X-Deluxe with Debian 3.0 (Woody), and a custom compiled kernel (version 2.4.18).

The CD that comes with the mobo has "support" for the 3COM NIC for linux, or so it claims; both the CD and the website claim that the newest and correct driver is "3C90x-102.tar.gz".

This has some source in it, which I have successfully compiled.

However, the module will NOT load properly, claiming it cannot find the NIC. I edited the source-code of the header file of the module, and turned on debugging; the output is along the lines of "Found an unsupported NIC, aborting". At first I thought it was perhaps finding the nVidia one first, so I installed the nVidia drivers and got that port working (successfully!). However, the 3Com driver (3C90x) still has the same error -- it would seem that they don't have support in this driver for the ASIC of the NIC on the a7n8x-deluxe (exact ASIC is 3C920B-EMB).

I also tried Donald Becker's driver - 3c59x - this doesn't support the 3C920B-EMB either. Damn!

Has anyone here succesfully used the 3c90x-102.tar.gz that came on the mobo CD ? I checked the module itself and there's no way to tell it where the 3com nic is (I/O or IRQ I mean). Yargh!

Any help would be much appreciated, I want both of my NICs working in linux.

Tim

#2 Xaphod

Xaphod

    stranger

  • Members
  • 2 posts

Posted 30 January 2003 - 01:20 AM

Yes, after much hassle it's now working. Some source-code tweaking was needed.

Solution is here:

http://www.nforcersh...opic.php?t=4648

tim




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq