Jump to content
Compatible Support Forums
Sign in to follow this  
mdlc

KDE installation for MANDRAKE 10 fails on a SONY VAIO PCG-GRT816M Notebook

Recommended Posts

Hi all!

 

I have a SONY VAIO PCG-GRT816M Notebook, P4 2.8 Ghz, nVidia GeForce FX Go5600 videocard. I have real difficulties installing Mandrake 10.0 on it. KDE and GNOME fail to start properly with constant crash messages for various applications: mandrakegalaxy.real, kcminit, ksplash, knotify. They all cause the signal 11 (SIGSEGV) to be sent.

 

As I don't know what the problem is related to, let me resume the different obstacles I encountered and how I solved them. I may have performed bad operations...

 

First I had to boot typing "linux noapic" at the boot prompt or the default kernel would hang just after checking the hard disk.

 

Then I would proceed through the installation procedure just fine, and reboot the machine. There, problem with the Xserver that fails to start, and no graphical interface would show up.

 

I installed the driver NVIDIA-Linux-x86-1.0-6111-pkg1 (frankly I ignore the real meaning of this syntax) and modified the "Device" Section of the XF86config file for the following option:

 

Identifier "VESADevice"

Driver "vesa"

 

I have actually no idea if this is the good option of driver but I managed to make it work anyway. So finally I could get the graphical interface, but KDE keeps on crashing at every userlogin, for applications kcminit, ksplash, knotify, mandrakegalaxy.real... And then freezes after closing all messages!

 

Does anyone have a brilliant idea to propose me?

 

Thanks in advance,

mdlc

 

 

Share this post


Link to post
Share on other sites

Did you do the install from the command prompt after exiting from the x server?

 

Also, try changing your Driver "vesa" option, as per the directions;

 

 

"If you already have an X config file working with a different driver

(such as the 'nv' or 'vesa' driver), then all you need to do is find

the relevant Device section and replace the line:

 

Driver "nv"

(or Driver "vesa" )

 

with

 

Driver "nvidia"

 

In the Module section, make sure you have:

 

Load "glx"

 

You should also remove the following lines:

 

Load "dri"

Load "GLcore"

 

Share this post


Link to post
Share on other sites

hi

 

i have resolved your problem

sorry i m french so my english is no good....

 

i have the same computer vaio PCG GRT816M than you

 

 

just install the nvidia driver 6229 on nvidia site...

and modify your XF86Config file---->

 

section device

Identifier "device1"

Driver "nvidia"

Option "NvAGP" "1"

EndSection

 

 

that's all ....

 

 

it work good .

bye

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×