Jump to content


Photo

Is new Asus P5GD2 linux compatible???


  • Please log in to reply
8 replies to this topic

#1 osten

osten

    stranger

  • Members
  • 2 posts

Posted 02 September 2004 - 09:32 PM

Hi, Im into buying a new box and want to asure that I will be able to run linux on it as I plan...

I have desperately searched the inet and lots of forums but with no success, please, can anybody give me feedback on the hw below, can I run linux on it????

- Intel Pentium 530, 3.0GHz, 800MHz, sock.775
- 512MB, PC2-4300/533MHz DDR2
- Asus P5GD2-Premium - 915P
- GeForce PCX5300, 128MB, PCI-Express

Please???

Regards,
Osten

#2 jimf43

jimf43

    enthusiast

  • Members
  • 397 posts

Posted 03 September 2004 - 12:38 AM

Tough question... Overall Asus has a great reputation, but, I think that the board just hasn't been out there long enough for anyone to give a difinative answer. Looking at the extended spec, I'd be concrned about a number of the onboard features compatability.

Here are the issues I see:

PEG16X One slot
* this is a new spec, and, although I wouldn' t expect problems, one never knows...

Audio CMI 9880 from ICH6/R - High-definition audio
* this is probably ok

IDE RAID ITE 8212F. 2 ATA133 ports. Capable of RAID0, RAID1, RAID0+1 and JBOD modes
SATA 4 ports from ICH6/R and a further 4 ports from Silicon Image 3114R controller
SATA RAID RAID0 and RAID1 from Intel Matrix Storage and RAID0, RAID1, RAID0+1, RAID5 (via software patch) and JBOD from Sil3114
* SATA is still problematic at times, but the controller is pretty mainstream, so, cross your fingers.

Networking Dual Gigabit Ethernet Controllers. Marvell 88E8001-LKJ PCI-based controller and 88E8053 PCI Express-based controller
* I don't have experence with this one and network cards/chips can be a problem.

Networking Wireless Marvell 88W8310 two-chip 802.11g Wireless controller with on-board antenna port
* this is the one that scares me. If network cards/chips can be a problem, then wifi can be a nightmare. I seriously doubt there is curent support.

As you should know by now, hardware support in Linux can lag behind the latest and greatest. I'm pretty certain that, sooner or later, this will all be suported. Right now I'm not sure that you can get everything working. Without booting Mepis or Koppinx to verfy some of the features, I don't know how you can tell for sure. Of course that means that you bought the board ;-)


#3 osten

osten

    stranger

  • Members
  • 2 posts

Posted 04 September 2004 - 07:26 PM

Thx for the very detailed reply, I will buy the mobo and cross my fingers, I don't need the wifi, but 8xSATA and gigabit is vital...

/ึsten


#4 hejhopp

hejhopp

    stranger

  • Members
  • 2 posts

Posted 12 September 2004 - 09:10 PM

Hi, i was planning on buying that mobo aswell and the 2.6 kernel seems to have support for most of the components. however i'm not certain about the marvell 88e8053 gbit ethernet controler. the 80e8050 controler seems to be supported though. so my question is, has anyone tried this mobo and/or this specific controler and got it working?

#5 stetrick1

stetrick1

    stranger

  • Members
  • 1 posts

Posted 31 January 2005 - 01:35 AM

In brief, this has not been a pretty install. I have just gotten the P5GD2 Premium, and prepare for some work.

If you want to install from CD, it appears that the CD must be connected to the ICH6 IDE controller. If you have other drive(s), they are likely connected to the ID8212 controller.

Suse 9.2 doesn't see these hard drives and doesn't install. Instructions on the 8212 driver download don't make sense, and after several tries, I could get it to install.

Mandrake 10.1 doesn't see the Marvell network controllers, which makes updates a bit difficult. Again, not easy to make work.

Gentoo 2004.3 sees neither the drive nor the network. A no-hitter.

Life may be better if you have SATA drives.

Any insights would be appreciated.

#6 moobar

moobar

    stranger

  • Members
  • 1 posts

Posted 09 June 2005 - 12:43 AM

Using an IDE connected CD/DVD drive and a SATA disk the install went quite ok using the Fedora FC4 pre-release.

I got Gigabit Ethernet card to (sort of) work using the driver one can download from the ASUS page. However, there is a big BUT. The driver is not entirely stable and every so often the card needs to be restarted (ifdown eth0 ; ifup eth0). Also the driver is using depreciated kernel functions that are not available in 2.6.11 and needs some additional patching before it compiles. Last but not least once the kernel patch has been generated a complete kernel rebuild is required.
So, this is not really working solution. The kernel seems to support the 8051 and 8052 card but not the 8053 card. Does anyone have a better experience?

As for the Wireless card... any help would be greatly appreciated.


#7 mondi_lv

mondi_lv

    stranger

  • Members
  • 1 posts

Posted 05 September 2005 - 06:16 PM

About Yukon - problem in the kernel, I think. Just few developers (SuSE, Ubuntu...) made attention to sk98lin driver.
Use last SysKonnect driver - at asus site wrong driver too.
But for 88W8310 (wifi) still is problem. Anybody find compatible driver?


#8 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 06 September 2005 - 03:12 AM

Just as a note, fedora Core 4, Mandrake 10.2 and SuSE 10 (beta) support the Gigabit Ethernet onboard cards well.

In terms of wireless, I found this thread.

#9 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 07 September 2005 - 12:03 PM

I also found the Linux compatibility tests for this model here, which states that there is no compatibility with RedHat, SuSE and Mandrake. Of course, these results may not be totally up-to-date.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq