Jump to content


Photo

No sound since upgrade to Fedora Core 2 Kernal 2.6.8-1.521


  • Please log in to reply
5 replies to this topic

#1 jpc1258

jpc1258

    stranger

  • Members
  • 2 posts

Posted 27 August 2004 - 08:20 PM

I'm running Fedora Core 2 Kernal 2.6.8-1.521 on a Toshiba Satellite A65-12S Laptop. My problem began when I upgraded the kernel to the current version. I lost my sound, it was working in Kernel 2.6.5-1.358. Below are the outputs from /sbin/lspci and $uname -r

[root@localhost sbin]# lspci
00:00.0 Host bridge: ATI Technologies Inc: Unknown device cab3 (rev 05)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
00:13.0 USB Controller: ATI Technologies Inc: Unknown device 4347 (rev 01)
00:13.1 USB Controller: ATI Technologies Inc: Unknown device 4348 (rev 01)
00:13.2 USB Controller: ATI Technologies Inc: Unknown device 4345 (rev 01)
00:14.0 SMBus: ATI Technologies Inc ATI SMBus (rev 18)
00:14.1 IDE interface: ATI Technologies Inc: Unknown device 4349
00:14.3 ISA bridge: ATI Technologies Inc: Unknown device 434c
00:14.4 PCI bridge: ATI Technologies Inc: Unknown device 4342
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97 Audio Controller
00:14.6 Modem: ATI Technologies Inc: Unknown device 434d (rev 01)
01:05.0 VGA compatible controller: ATI Technologies Inc: Unknown device 4437
02:04.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
02:06.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
02:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

[root@localhost /]# uname -r
2.6.8-1.521
The output from soundcard detection is:
Vendor: ATI
Model: IPX150 AC'97 Audio Controller
Module: snd-atiixp

Any Suggestions?

Thanks in Advance

#2 Beej-in-GA

Beej-in-GA

    stranger

  • Members
  • 17 posts

Posted 27 August 2004 - 09:59 PM

Originally posted by jpc1258:
Quote:
I'm running Fedora Core 2 Kernal 2.6.8-1.521 on a Toshiba Satellite A65-12S Laptop. My problem began when I upgraded the kernel to the current version. I lost my sound, it was working in Kernel 2.6.5-1.358. Below are the outputs from /sbin/lspci and $uname -r

[root@localhost sbin]# lspci
00:00.0 Host bridge: ATI Technologies Inc: Unknown device cab3 (rev 05)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
00:13.0 USB Controller: ATI Technologies Inc: Unknown device 4347 (rev 01)
00:13.1 USB Controller: ATI Technologies Inc: Unknown device 4348 (rev 01)
00:13.2 USB Controller: ATI Technologies Inc: Unknown device 4345 (rev 01)
00:14.0 SMBus: ATI Technologies Inc ATI SMBus (rev 18)
00:14.1 IDE interface: ATI Technologies Inc: Unknown device 4349
00:14.3 ISA bridge: ATI Technologies Inc: Unknown device 434c
00:14.4 PCI bridge: ATI Technologies Inc: Unknown device 4342
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97 Audio Controller
00:14.6 Modem: ATI Technologies Inc: Unknown device 434d (rev 01)
01:05.0 VGA compatible controller: ATI Technologies Inc: Unknown device 4437
02:04.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
02:06.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
02:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

[root@localhost /]# uname -r
2.6.8-1.521
The output from soundcard detection is:
Vendor: ATI
Model: IPX150 AC'97 Audio Controller
Module: snd-atiixp

Any Suggestions?

Thanks in Advance


Have you tried running alsamixer as root from a terminal prompt? Check to see if anything is muted. If it is, unmute it and escape back to the prompt. At the prompt type "alsactl -store" again as root after to testing sound card with "Detect Sound card" under system tools I think on the Red Fedora menu. This is supposed to fix the problem though it isn't the same card, you could check a thread called "Audigy issues with Fedora Core 2" in this forum. Some answers may apply. I am the one having the sound problem. We have it fixed manually, now working on getting to automatically setup at boot up. I am running the same kernel as you on an intel p4 2.4GHz processor.
Best Regards,
Beej


#3 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 27 August 2004 - 10:59 PM

since the sound was working with the only difference being a kernel version,
you might try the boot parameter "acpi=noirq". It makes the difference
between a couple of things working versus not working for me with a 2.6 kernel.
(one of which is sound)



#4 jpc1258

jpc1258

    stranger

  • Members
  • 2 posts

Posted 14 September 2004 - 09:14 PM

Hey martouf when would I enter the command?

#5 OldSpiceAP

OldSpiceAP

    member

  • Members
  • 134 posts

Posted 15 September 2004 - 07:56 PM

I had a similar problem with yoper linux and with SuSE Linux. The solution that worked for me was to download the source for alsa and compile it under my newer kernel. I had to have my kernel-source for the compile, but I don't know if that has anything to do with my distro or not since I didn't find anywhere that it was required.

Hope you get it all working! Good Luck

#6 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 16 September 2004 - 03:58 AM

jpc1258: "boot parameter" == passed to the kernel at boot time.

compare the regular boot string with any 'safe mode' entry in your bootloader,
just to see what different boot parameter lists look like...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq