Jump to content


Photo

Kernel 2.6.8.1 & Web Browsing Issues


  • Please log in to reply
15 replies to this topic

#1 anthonyi

anthonyi

    stranger

  • Members
  • 16 posts

Posted 24 August 2004 - 05:02 PM

Hi,

I'm running FC2 and using a Belkin 54g wireless card/router connected to my cable modem (NTL). I use the Linuxant Driverloader software (latest version) to load Windows drivers for my wireless card.

Under Kernel 2.6.7 and earlier, everything is fine. However, under 2.6.8.1 and above (both kerbel packages from kernel.org and the vanilla FC2 kernel rpm) I have problems accessing *some* and only *some* websites. The issue appears as very, very slow loading. When I boot back to a 2.6.7 kernel the issue disappears; it also disappears when I boot into WinXP. The issue is entirely reproducable and affects the same websites each time.

I'm guessing it's a kernel configuration issue, but having stepped through the config options I can't find the one that's causing me a problem...

Any ideas? It's driving me nuts... :-)

Anthony



#2 egorgry

egorgry

    enthusiast

  • Members
  • 315 posts

Posted 24 August 2004 - 05:26 PM

I had a similar problem using 2.6.6 with Debian/Sid. IT was something with ip6. Can you get to either of these two sites?

http://www.videohelp.com/

http://disney.store.go.com/

It may be the same issue I was having. I'll try to remember how I fixed it.

#3 anthonyi

anthonyi

    stranger

  • Members
  • 16 posts

Posted 24 August 2004 - 05:44 PM

Hi,

I can get to those...an example site that I have problems with is http://www.majorgeeks.com

It loads fine when running 2.6.7 but is extremely slow under 2.6.8.1 - it does appear *eventually* but something is clearly not right.

Some time ago I added the following lines to /etc/modprobe.conf

alias net-pf-10 off
alias ipv6 off

which was supposed to fix the ipv6 DNS address resolution issue (and did seem to for 2.6.7). I've tried remming out these lines and booting 2.6.8.1 again but it made no difference.

I can't see this as anything other than a config issue but I've reached the limit of my linux knowledge (converted a couple of months ago so still very new to this stuff).

Cheers,
Anthony



#4 egorgry

egorgry

    enthusiast

  • Members
  • 315 posts

Posted 24 August 2004 - 08:38 PM

Try this peice of code below on the cmd line and see if you get some improvement. I have it as a startup script. Remember this is debian and I know little about redhat or fedora.


-------------------------
start up script goes in.
-------------------------
./init.d/dumbfix.sh
./rcS.d/S76dumbfix
--------------------
code
-----------------------------------
echo 0 > /proc/sys/net/ipv4/tcp_ecn
-----------------------------------

#5 anthonyi

anthonyi

    stranger

  • Members
  • 16 posts

Posted 24 August 2004 - 09:10 PM

Thanks for the suggestion...no joy with it, unfortunately. frown

Anything else I should be looking at?

Anthony

#6 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 24 August 2004 - 11:43 PM

was there a specific issue with the 2.6.7 kernel which prompted you to use
the 2.6.8.1 instead?

since you have both available, you could compare the varied /proc/sys/net/ipv4/*
and ipv6/* settings - that's just a guess, though. No need to look in ipv6
if 'ifconfig' doesn't have a 'inet6 addr' line.

what's the most recent kernel Linuxant has tested their driver?

my 0,02 - use what works and don't update the kernel unless you have a specific
security/driver reason.



#7 anthonyi

anthonyi

    stranger

  • Members
  • 16 posts

Posted 25 August 2004 - 12:50 AM

I guess I'm just trying to educate myself a little about the process of compiling a kernel that best matches my hardware.

I see that Linuxant have released version 2.05 of their driver today, so I'll try that first.

Thanks for the input.

Anthony

#8 anthonyi

anthonyi

    stranger

  • Members
  • 16 posts

Posted 25 August 2004 - 12:53 AM

Nope, the Linuxant driver upgrade did zip.

Back to looking at my kernel config!

#9 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 25 August 2004 - 03:06 AM

ok, if you're getting joy from building kernels, then one thing you could do
is compare the original 2.6.7 config very carefully against the 2.6.8.1 config.
(if you haven't already, that is)

"diff /boot/config-2.6.7 /boot/config-2.6.8.1"

anything interesting in the output?

one way of expressing the design philosophy (as I understand it) is the kernel
that best matches your hardware is the kernel which has loaded the modules
your hardware needs.



#10 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 25 August 2004 - 03:08 AM

I bet the kernel does not have DHCP set to run on startup as a module or compiled into the kernel. Darn, I wish I could remember where the setting is exactly in the network modules during the compile.

#11 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 25 August 2004 - 03:46 AM

uuuhhh, but DHCP is done by daemons or userspace client utilities.

you thinking about something else?


#12 anthonyi

anthonyi

    stranger

  • Members
  • 16 posts

Posted 26 August 2004 - 01:38 PM

2.6.9-rc1 didn't help either...

Looks like I'm stuck with 2.6.7 for the time being...not that that is a problem, I just want to know why I have this problem!

Thanks all for the input.

#13 richardwest

richardwest

    stranger

  • Members
  • 2 posts

Posted 19 September 2004 - 11:13 PM

I was having the same problem and after much searching I found a solution, I think it was on a kernel list.
I quote:-

-----------------

echo 0 > /proc/sys/net/ipv4/tcp_default_win_scale


or by adding a line like:


net.ipv4.tcp_default_win_scale = 0


to /etc/sysctl.conf.

-----------------

Apparently it actually due to a bug in some routers.

#14 jrift

jrift

    stranger

  • Members
  • 1 posts

Posted 17 October 2004 - 07:06 PM

Hi all. I joined the forum just to say thanks. The above solution worked for me with FC2 2.6.8-1.521 behind a cheap Belkin cable/dsl Router - sorry I can't remember or easily find out the exact make (I have to go to another room for that!)


#15 richardwest

richardwest

    stranger

  • Members
  • 2 posts

Posted 19 October 2004 - 12:04 AM

Glad I was able to help someone. I found the info here-

http://lwn.net/Articles/92727/

#16 c0$

c0$

    stranger

  • Members
  • 1 posts

Posted 19 March 2005 - 10:31 PM

Actually, for SuSe9.2 it's a little bit different. You need to fix this behavior with either:
# echo 0 > /proc/sys/net/ipv4/tcp_window_scaling
# or adding /etc/sysctl.conf
net.ipv4.tcp_window_scaling = 0
to /etc/sysctl.conf, followed by the cmputer's restart

http://guard.dhs.org...ken_router.html





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq