Jump to content
Compatible Support Forums
Sign in to follow this  

Tried everything I can think of. Need to load windows after Mandrake 10

Recommended Posts

I have read similar posts but anything suggested in them didn't work for me.

I loaded Mandrake 10 on a new PC a while back. I now want to run windows on it but try as I might, I can rid the hard drive of the MBR.

I have tried fdisk /mbr and the Maxtor Maxblast tools. I have also tried something called CasperXP which clones drives. Whatever I do, I end up with the same problem. I start to load XP but when the machine reboots, it gives a 'can't load operating system' or similar error.

I gave up a while ago and reloaded Mandrake 10, which works fine. The half loaded windows is still there but didn't boot using the option in lilo. I got smart and tried to copy another XP hard drive on an identical system but when I try to boot into windows, it still sits at a flashing dos prompt.

Ideally I would like to keep the dual boot but I don't know how to load windows with an existing linux load. Otherwise, I would also be happy to delete linux and get windows on the machine.

Thanks in advance for any help.

Share this post

Link to post
Share on other sites

You can try to use linux fdisk. Just boot into linux get a command prompt as root and type fdisk /dev/hda or whatever your partition is. type m for help follow the prompts. You may be able to wipe out enough space to get windows installed. I'm just suprised none of the other soulutions you read worked this is a pretty common problem that is normally easy to solve.


...Oh if you can get your hand on a copy of partition magic your life would be much easier. smile

Share this post

Link to post
Share on other sites

you may need to start with a version of Windows labelled "for PCs without an

Operating System" (or words to similar effect) - a version which comes

with a boot disk. The versions labelled "Upgrade" might not help you very much. frown


if you have a system restore disc instead of bootable WinXP, be aware what it

will probably do is restore the 'factory stock' ('as shipped') hard disk image.


if your WinXP disc is bootable, the recovery console should be able to fix the MBR

issue, but be aware it will prevent Mandrake from booting until you can boot

a Mandrake disc and reinstall the Grub (or Lilo) bootloader.


Speaking of Lilo - the original bootsector when you loaded it (or caused it

to be loaded) should still be found in /boot/boot.NNNN where NNNN is the name

of the device where the new MBR was written.


You might check the saved bootsector contents with 'xxd /boot/boot.NNNN'

to see if it's a Microsoft bootsector. If it is, you could restore it

with '/sbin/lilo -s /boot/boot.NNNN -u'. Be aware if you do so, then you'll

be at paragraph #3 (above).



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this