Jump to content


Photo

Register default Internet programs, email on web browser


  • Please log in to reply
10 replies to this topic

#1 Whiskers

Whiskers

    journeyman

  • Members
  • 99 posts

Posted 21 August 2004 - 02:51 AM

If I click on a link in instant messaging or something, it opens up mozilla as my default browser, where I would prefer it to open firefox instead.

Also when you click on an email link in a browser it says "
"error mailto is not a registered protocal"

#2 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 21 August 2004 - 06:52 AM

I believe Firefox has a way for you to tell it to use a specific email program as does Mozilla. I have the same problem with Evolution. If I click on a link from an email, it defaults to Mozilla, then to konqueror. Anyone know how to make Firefox my browser default when clicking links in Evolution?

#3 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 21 August 2004 - 12:43 PM

Well, I looked at the Firefox help section on their website. In terms of the default browser;

Quote:
Default Browser

On Windows, you can set Firefox as the default browser by clicking Set Default Browser. This will ensure Firefox is used whenever an application is trying to display a web page or when you double-click a HTML file. This feature does not work in Linux or Macintosh.


#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 21 August 2004 - 01:08 PM

Dan, I found this

Does the below section help?



Quote:
Mozilla & Firebird users, try this:
Install Mozex from http://mozex.mozdev.org/
Got to Edit -> Preferences -> mozex
(Firebird: Tools -> Preferences -> Extensions -> mozex -> Options)
Enter the following information:
General
[X] Intercept mailto: clicks
Commands
Mailer: evolution mailto:%A?Subject=%S&Cc=%C&body=%B


#5 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 21 August 2004 - 04:50 PM

Actually I did install mozex once and it does work with Mozilla. I didn't know it would work with Firefox though, thanks!

#6 Whiskers

Whiskers

    journeyman

  • Members
  • 99 posts

Posted 21 August 2004 - 09:59 PM

I cant find the mozex panel in my prefrences frown

http://mozex.mozdev....stallation.html

followed that page instructions, and yes when I right click there isa new entry that sayss mozex

#7 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 22 August 2004 - 03:37 AM

Actually, you can install mozex as an extension from within Firefox. Tools-->options-->extensions-->get new extensions.

Restart Firefox

You get the mozex preferences by doing Tools-->options-->extensions-->(highlight mozex)-->Options.

#8 jimf43

jimf43

    enthusiast

  • Members
  • 397 posts

Posted 22 August 2004 - 05:52 AM

Originally posted by Whiskers:
Quote:
If I click on a link in instant messaging or something, it opens up mozilla as my default browser, where I would prefer it to open firefox instead.

Also when you click on an email link in a browser it says "
"error mailto is not a registered protocal"

Are you using KDE or Gnome?

In KDE you can set the prefered program to open html and the prefered mail client in the control center. I'd be suprised if Gnome didn't have something similar.

#9 Whiskers

Whiskers

    journeyman

  • Members
  • 99 posts

Posted 22 August 2004 - 06:48 AM

I'm using KDE 3.2 where can I find the control center?
and I pasted went to get extensions and was able to get mozex that way, but somethign didnt work when i tried to send an email.
I did a screen capture of the error, but I dont know how to upload an attachment here.

I followed these directions

Mozilla & Firebird users, try this:
Install Mozex from http://mozex.mozdev.org/
Got to Edit -> Preferences -> mozex
(Firebird: Tools -> Preferences -> Extensions -> mozex -> Options)
Enter the following information:
General
[X] Intercept mailto: clicks
Commands
Mailer: evolution mailto:%A?Subject=%S&Cc=%C&body=%B

#10 jangus

jangus

    stranger

  • Members
  • 1 posts

Posted 22 October 2004 - 08:08 AM

Originally posted by Whiskers:
Quote:

Commands
Mailer: evolution mailto:%A?Subject=%S&Cc=%C&body=%B


For the record, I had to specify the full path to evolution under my Knoppix 3.2 (hard disk installation) using Firefox 0.92 and Evolution 1.4.5 ie:

Mailer: /usr/bin/evolution mailto:%A?Subject=%S&Cc=%C&body=%B

#11 Whiskers

Whiskers

    journeyman

  • Members
  • 99 posts

Posted 22 October 2004 - 08:43 PM

/usr/bin/evolution mailto:%A?Subject=%S&Cc=%C&body=%B

Are those % supposed to be included or is that something weird done by the message forum? I think I may have taken those out.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq