Jump to content
Compatible Support Forums
Sign in to follow this  
jscott

No center speaker sound with SoundBlaster Live! 5.1 and 5.1 speakers

Recommended Posts

I recently upgraded my OS from Windows ME to Windows XP Pro, and replaced my old sound card with a SoundBlaster Live! 5.1 card (not digital) and Creative Inspire T5400 5.1 speaker set. The XP drivers I used are the ones that came on the Creative CD (which is dated late 2003 but the XP drivers on the Creative downloads is dated early 2003???). Anyway...

 

When testing the speakers using the Creative Mixer, I can hear sounds from all 5 speakers (left rear, right rear, left front, right front, and center). However, standard Windows sounds, Winamp 5, PowerDVD, or any applications in Windows do NOT play sounds from the center speaker. I haven't tried any games yet since I just installed the card last night. I have Windows audio

properties set to 5.1 Speakers but I cannot get any sound from the center speaker. Sound will only come from it when testing speakers in Creative Mixer.

 

Short list of PC Specs:

ASUS P2B-F mobo, no on-board audio

PIII 1GHz CPU

512MB RAM

WinXP Pro SP1

Hercules GeForce 3 AGP card, 64 MB RAM

 

Can anyone tell me what I need to do to fix this?

Thanks,

Jon.

 

Share this post


Link to post
Share on other sites

Many applications only put out to stereo even if you have 5.1 enabled.

 

If you wish to see if your center speaker works in a game, try it out there, provided the game can make use of 5.1 surround. If you don't have such a game, you could download a demo of a game with such surround capabilities, or even get Army Ops (which isn't a demo, but a full game, and a good one at that) and try it out.

 

Some surround speakers have a mode (Logitech calls it "Matrix" ) that will force a mix of the left and right channels to the center. Perhaps your speakers have this. Or, there might be an option in your soundcards control panel. Either way, this isn't 5.1 discrete channels, but if the app isn't putting out an separate signal to the center channel, than it's got to be faked someway if the center is to put out sound.

 

Do you have a version of PowerDVD that has 5.1 surround available? If so, have you checked the preferences in PowerDVD to have 5.1 activated?

 

I don't know much about winamp. Not sure if it uses center or not.

Share this post


Link to post
Share on other sites

Never mind, finally got it working. If anyone needs to know, you have to install Creative PlayCenter (even if you'll never use it) and enable CMSS. Sounds/music from any apps now come

from all speakers.

 

Thanks,

Jon.

 

Share this post


Link to post
Share on other sites

i have the same problem as this i have an audigy with a 5.1 system when i play the small movie (the one with the aeroplane and the motorbike the 5.1 runs fine when i test all the speakers the centre works fine but when i put a movie on nothing from the centre same with games as well, i saw you said you needed playcentre which ive installed but where do u change the setting ??????

Share this post


Link to post
Share on other sites

hello jScott.

Can you please tell me where can I find the configuration for CMSS? Or, at least, the version of PlayCenter that you have, as I couldn't find the section where to enable/disable CMSS... PLEASE HELP ME ! I'M DESPERATE ! Thanks

Share this post


Link to post
Share on other sites

With my Audigy 2 I can access CMS settings via the sound icon on my taskbar or by going to Audio HQ in the control panel, or by selecting EAX Console. The Audigy is different from the Live and the steps are a bit different, but CMS allows standard stereo to be upmixed to 4.1/5.1/6.1/7.1 audio.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×