Jump to content


Photo

Tell linux to stop trying to automount my external drive on boot


  • Please log in to reply
6 replies to this topic

#1 Whiskers

Whiskers

    journeyman

  • Members
  • 99 posts

Posted 18 August 2004 - 05:34 AM

I have an external usb 2.0 drive, partitioned and mounted as follows

/usb1
/usb2
/usb3

are all fat 32 partitions, on boot, it trys to mount these 3 partitions and says failed , and im thinking, well duh, the driveis only for backing up data, and its not plugged in. I would like it to stop trying to mount this drive on boot, if i want to mount it I will do some manually with the mount command. Also when it gets mounted it would be nice to be able to write to it :P, currently I have to log into X as root, yes i know thats not a good idea, but it was the only way i could access the drive. Tried changing the drives chmod to 777 and tried changing the access under the mount properties (it shows 3 folders where it mounts the drive to /usb1 /usb2 and /usb3

Any help would be appreciated and thanks smile

#2 res0r9lm

res0r9lm

    stranger

  • Members
  • 1 posts

Posted 18 August 2004 - 09:42 AM

changing options in /etc/fstab to noauto,rw,users should work

#3 Whiskers

Whiskers

    journeyman

  • Members
  • 99 posts

Posted 18 August 2004 - 08:31 PM

/dev/hda1 / ext3 defaults 1 1
/dev/hdb1 /Oneniisama ext3 defaults 1 2
none /dev/pts devpts mode=0620 0 0
/dev/hdc /mnt/cdrom auto umask=0022,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
/dev/hdd /mnt/cdrom2 auto umask=0022,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0022,iocharset=iso8859-1,sync,codepage=850 0 0
none /mnt/removable supermount dev=/dev/sda1,fs=ext2:vfat,--,umask=0022,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /proc proc defaults 0 0
/dev/sdb1 /usb1 vfat defaults 0 0
/dev/sdb2 /usb2 vfat defaults 0 0
/dev/sdb3 /usb3 vfat defaults 0 0
/dev/hda5 swap swap defaults 0 0
none /mnt/hd supermount dev=/dev/ide/host0/bus0/target1/lun0/part1,fs=ext2:vfat,--,umask=0022,iocharset=iso8859-1,kudzu,codepage=850 0 0
none /mnt/removable2 supermount dev=/dev/scsi/host0/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0022,iocharset=iso8859-1,kudzu,codepage=850 0 0


where and how does it go in? and that /mnt/removable2 i think was the orginal /mnt/ but its not used anymore, is it safe to delete it?

I really dont want to mess with this untill i know that im doing.

#4 pjs1976

pjs1976

    stranger

  • Members
  • 1 posts

Posted 18 August 2004 - 10:50 PM

man fstab

it will tell you how to format the file.

man mount

to see the options and what they do.

The list of options he gave you go in 4th field and fields are seperated by tabs or space. Just paste them there.


#5 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 19 August 2004 - 05:20 AM

I think res0r9lm hit the nail on the head and drove it all the way home in a single
stroke. If you blinked at the moment of impact, you missed the show.

Whiskers: edit your fstab file and replace "defaults" with "noauto,rw,users"
for each of the usbX disks.



#6 Whiskers

Whiskers

    journeyman

  • Members
  • 99 posts

Posted 19 August 2004 - 07:08 AM

Originally posted by martouf:
Quote:
I think res0r9lm hit the nail on the head and drove it all the way home in a single
stroke. If you blinked at the moment of impact, you missed the show.

Whiskers: edit your fstab file and replace "defaults" with "noauto,rw,users"
for each of the usbX disks.




so it would look like?

/dev/sdb1 /usb1 vfat noauto,rw,users

or do the 0,0 stays also?

#7 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 19 August 2004 - 08:13 PM

exact string substitution - everything else in the line remains exactly
as you found it.

substitute the chars "noauto,rw,users" where the chars "defaults" appear.
leave the rest as you found it.

In Perl string substitution code: s/defaults/noauto,rw,users/;

not to overthink this .. just _do_. laugh

(yes, the "0 0" remains)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq