Jump to content


Photo

Is there a driver for ATI Radeon X300 SE ???


  • Please log in to reply
9 replies to this topic

#1 tags142

tags142

    stranger

  • Members
  • 2 posts

Posted 20 July 2004 - 02:20 AM

Does anybody know if a linux driver exists that works with
the new ATI Radeon X300 SE PCI-express graphics card ?

I don't need high performance, I just need basic
functionality. Does the proprietary ATI Radeon driver
work for this ?

How long does it usually take for new cards to become supported ?

Thanks for your help !

#2 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 20 July 2004 - 04:27 AM

According to this, your card should function under Linux. Is it not working now? With which distro are you wanting it to work?

#3 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 20 July 2004 - 06:10 PM

Would you kindly be more descriptive and specific in stating
what your difficulty is?

Or are you simply asking "is this card supported? will I make
a horrible mistake if I buy it?" ??

'fess up! 8)

#4 tags142

tags142

    stranger

  • Members
  • 2 posts

Posted 21 July 2004 - 10:23 PM

Martouf :

I am simply asking "Is this card supported? Have I made
a horrible mistake by ordering it ?"



Thanks Dapper Dan,
I also found this link but I'm not sure I trust it.
ATI's website does not say that this card is
supported and nobody else seems to know.

#5 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 22 July 2004 - 01:04 AM

let's see, I've encountered your question on the Rage3d.org Linux board
and the linuxforums.org Peripherals/Hardware board. You get around, eh?

Best I can tell, the X300 has the RV370 VPU and it probably going
to work with the radeon Xorg driver, being how it is still part
of the Radeon family - documentation here

You may need to 'trick' the driver by providing the ChipID for the RV360 VPU, however.
(see the documentation)

Install your distro, and come on back here if there's any trouble.



#6 roob85

roob85

    stranger

  • Members
  • 1 posts

Posted 30 November 2005 - 01:16 PM

well i have a question about this card...im using it on a dell dimension 8400 which has a p4 3.6Ghz cpu and 512 of ram.....my problem is that when i use the ati driver i got from there site for 3d....my computer is freezing up..totaly unresponsive....ive tried so many things....i tried a older driver...still did it...the newstone still does it....andyone have any ideas..they would be much appreciated...btw im currently on mandriva 2006

#7 Klondike

Klondike

    stranger

  • Members
  • 1 posts

Posted 23 December 2005 - 02:49 PM

Also worth mentioning is my case ,where I just installed Ubuntu with this card, and X Windows will not start. It says "No screens found". That's all. It lists the card as an ATI Radeon - Unknown Device in most of the config files and logs. I'd like to make sure my drivers are up to date, and use any "tricks" if necessary, but the link above to documentation on how to do it is out of date.

#8 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 23 December 2005 - 06:28 PM

Realize that the article post is over one year old.

Roob85, what distro and version are you using?

Did you download the driver and follow the directions on the ATI site located here?

#9 doon41

doon41

    stranger

  • Members
  • 2 posts

Posted 06 February 2006 - 11:08 AM

I have tried SuSE 9.3 and 10.0 retail, and 10.1 Beta3 (download), to no avail. (all x86_64)

The 10.0 retail starts booting, then dies with
Kernel Panic: not syncing: attempted to kill init.
It looks like it is trying to use /dev/sda2 which would be correct.

The 9.3 and 10.1B load the kernel and immediately hang with the monitor black and its message saying "out of range" which I presume means the signal is garbage or invalid.

My config:
Asus A8N-SLI, 1GB, AMD64 3700+
LSI 20320R (4 drives) and one WD Raptor on the SATA bus
ATI Radeon X300 on PCI-Express with NEC Multisync LCD1770GX
Sony CDU-810A multi-format CD/DVD

I have Win XP Pro x64 on the first (boot) SCSI drive and it runs just fine. :-(

FWIW, I have seen various installation hangups with Ubuntu (cant read the loader component). Fedora installs and runs but looks crappy with 800x600 (and its first kernel update panics). SLAX 5.0.7 boots fine and runs, but I want a more complete system, and what I really want is SuSE. Sigh.

#10 doon41

doon41

    stranger

  • Members
  • 2 posts

Posted 06 February 2006 - 12:36 PM

I found a solution for SuSE and Radeon X300. Stupid me. I have to set the resolution on the boot screen to something less than maximum (default). Then it seems to be willing to go ahead. Oh yes, I also have to remove the LSI20320R SCSI adapter, and install to the SATA drive. Maybe I can install to SATA, then install drivers for the LSI, then (with luck) move the SuSE system over to a SCSI drive.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq