Jump to content
Compatible Support Forums
Sign in to follow this  
brodee

mounting vfat volumes with rw Privileges for a user

Recommended Posts

how I have it right now: I can only write to the vfat volumes when logged in as root. The user can read and execute files. I want to be able to do write files logged in as the user.

 

ok, so here is my fstab file:

LABEL=/ / ext3 defaults 1 1

LABEL=/boot /boot ext3 defaults 1 2

none /dev/pts devpts gid=5,mode=620 0 0

none /dev/shm tmpfs defaults 0 0

none /proc proc defaults 0 0

none /sys sysfs defaults 0 0

/dev/hdb5 swap swap defaults 0 0

/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0

/dev/cdrom1 /mnt/CDRW-DVDRW udf,iso9660 noauto,owner,kudzu,ro 0 0

/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

/dev/hda1 /mnt/Axolotl/ vfat defaults 0 0

/dev/hdb1 /mnt/Data/ vfat defaults 0 0

Share this post


Link to post
Share on other sites

here's what mine looks like... you need a rw option, and take away the 'defaults' it doesn't work like that. use a umask option.

 

 

/dev/hda1 /mnt/windows ntfs ro,umask=0222 0 0

/dev/hdb1 /mnt/stuff vfat uid=500,gid=500,users,rw,umask=0000 0 0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×