Jump to content


Photo

different gaim install problems on fedora


  • Please log in to reply
6 replies to this topic

#1 brodee

brodee

    stranger

  • Members
  • 18 posts

Posted 18 July 2004 - 06:45 AM

I try to install gaim with the following command :
rpm -ivh gaim-0.80-0mdk10.0.i586.rpm
and it says this
I then installed atk and glib and pango, ( apprently required for gtk) then I installed gtk 2.4 and the same error happens

warning: gaim-0.80-0mdk10.0.i586.rpm: V3 DSA signature: NOKEY, key ID 4c292fcc
error: Failed dependencies:
gtk+2.0 >= 2.0.0 is needed by gaim-0.80-0mdk10.0
libnss3 is needed by gaim-0.80-0mdk10.0
perl-base >= 2:5.8.3 is needed by gaim-0.80-0mdk10.0


that nokey error didn't happen until I got all the updates.
if anyone could help me that would be great.

thanks a lot

#2 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 18 July 2004 - 04:52 PM

Which distro?

#3 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 18 July 2004 - 07:33 PM

OK, after looking over this again a little closer, I see a "MDK" in that RPM. Did you already have Gaim as part of MDK 10? Was it not working or was it not icluded when you did the initial install?

#4 brodee

brodee

    stranger

  • Members
  • 18 posts

Posted 18 July 2004 - 10:20 PM

I have fedora 2. whatever the lastest version is. I think 2.6.0.438 or something

I don't know what version of gaim I was trying to install but I downloaded and compiled the source and it seemed to work sorta. it compiles but, you need to compile it with ssl libraries to use the MSN part of it.

so I installed GNUtls (and the packages required by GNUtls).

I then uninstalled, reconfigured, recompiled and reinstalled gaim.

the congurator, said that it was going to use the SSL libraries from GNUtls ...great

then when I try to run gaim it says the same error, that the ssl libraries are not installed.

on the gaim.sf.net/faq-ssl.php site it says to type this command:
ldd /usr/local/lib/gaim/ssl-gnutls.so
which gives me this result:
linux-gate.so.1 => (0x00a3c000)
libgnutls.so.12 => not found
libgcrypt.so.11 => not found
libnsl.so.1 => /lib/libnsl.so.1 (0x00732000)
libc.so.6 => /lib/tls/libc.so.6 (0x00eb8000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x00bbf000)
I have gnutls installed and I have libgcrypt installed, I don't know why it says not found.

when I installed the libraries I used the defualt options
./configure
make
make install

and sometimes I had to say LD_LIBRARY_PATH=/usr/local/lib/ ./configure

my only theory of why it doesn't work is because some libraries are installed in different places so no matter which way it is configured it misses out on some libraries. does that make sense?

anyway, I'm going to screw around with it some more.

I appreciate everyones help

-Brodee

#5 brodee

brodee

    stranger

  • Members
  • 18 posts

Posted 18 July 2004 - 10:45 PM

WOOOOOOOt, I can get it to use the libraries by typing in terminal:

LD_LIBRARY_PATH=/usr/local/lib/ gaim

is there anyway to change the shortcut on the panel to do this?

thanks.

#6 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 18 July 2004 - 11:50 PM

brodee, that RPM is for Mandrake 10. In most cases, it's not a good idea to use RPM's from another distro, as it can cause a problem somewhere else. Gaim is included with Fedora Core 1 and Core 2, and I've run it successfully under both. To whatever degree it works for you now, I would still uninstall it..

rpm -e gaim-0.80-0mdk10.0.i586.rpm [enter]

And install the one that is correct for your distro.

You can install Gaim by apt-get RPM or just go as root:

system-config-packages [enter]

And look for it in the Multimedia section. Once installed, upgrade your whole system using either apt, yum or up2date, and Gaim should work as desired.
smile



#7 brodee

brodee

    stranger

  • Members
  • 18 posts

Posted 19 July 2004 - 01:35 AM

hi, well, I noticed that in order to run this other program I installed, I had to do that LD_LIBRARY_PATH thing as well

so I added it to my .bash_profile and now everything seems to be working.

on one hand the stuff I have installed works now so I don't want to screw with it.

the other hand sometimes the ./configure wouldn't work if I did LD_lib... because it would find 2 different versions of gtk, so I'm thinking that that might cause problems later.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq