Jump to content
Compatible Support Forums
Sign in to follow this  
Whiskers

Newbie Help , Need step by step nvidia driver install for Mandrake 9.2

Recommended Posts

I've got the nvidia driver and did the sh installername

and it says

 

 

ERROR: Unable to find the system utility `ld`; please make sure you have the

package 'binutils' installed. If you do have binutils installed,

then please check that `ld` is in your PATH.

 

then i heard that im supposed to change something inna file.

 

Thanks for any help

 

 

 

Share this post


Link to post
Share on other sites

I think you need to be root, not a regular user, when you run the "sh installername".

 

Login as root or "su - root", then try the Nvidia driver install again.

Note that's "su - root" not just "su".

 

You'll need the full root environment just as if you've logged in as root.

 

 

Share this post


Link to post
Share on other sites

It's good you're aware you needed to be root to do the install.

 

Ah, well then it seems you might not have the 'binutils' package installed (although it

occurs to me you really ought have 'ld' on your system somewhere or else many more

things than the nvidia driver install would have problems).

 

'ld' ought to be in /usr/bin and '/usr/bin' should be in the execution path

(check with "echo $PATH" ).

 

hmmm...

 

the installation instructions indicate there's nothing you need to do other than

"sh installername.mun".

 

What's your "echo $PATH" looks like? can you "ls -l /usr/bin/ld"?

Can you tell me what you have when you run "uname -a"?

Can you verify the 'binutil' package is installed?

Would you know how to install the package if it's missing?

 

Share this post


Link to post
Share on other sites

That exactly the file I'm trying to install. I pooched the install just half hour ago so im truging through reinstall as we speak, i did some updates and it got rid of all the programs in my start menu or whatever you call it in Linux.

 

How do I install that package? I dont know what it would be under, and I had to configure my card as a Geforce rather than the proper version of geforce else i wouldnt have X, and that woulb e baddddd

 

Without laughing too much at me, I've grown tired of Windoze and all its blue screens and irq errors, and ive looked into that I can play my games in Linux so this will be my gaming system :), but I need some help getting it set up.

Share this post


Link to post
Share on other sites

er correction when i set up the card during install , it said

 

"vesa" whatever that was but it gave me the resolution i wanted, the geforce fx drivers and other geforce drivers wouldnt give me that.

Share this post


Link to post
Share on other sites

Whiskers, "binutils" should be included with your distro install cd's. What distro are you using?

 

There is a special way to install that nvidia driver package.

 

 

You'll have to edit your /etc/inittab file. Become root and type "gedit", without the quotations and press enter.

 

click "open", and in the left hand pane, double click the "../ " 2 times.

 

In the left hand pane, scroll down to /etc and double click it.

 

look for "inittab" in the right pane, and double click it. gedit will then open the inittab file.

 

look for the line..

 

id:5:initdefault:

 

edit this line and change the "5" to a "3"

 

save, exit and reboot the computer.

 

This time, your "user manager thingie" will not come up for you to enter your name and password because you will now not be in X windows. You will have to enter your username and password at the command line to become root. Then go:

 

./NVIDIA-Linux-x86-1.0-5328-pkg1.mun [enter]

 

..and follow the instructions.

 

After completion, and at the command prompt, type "startx" and press enter. This will start X and will put you back in runlevel 5.

 

log in as usual, and return to gedit as above. Go back to /etc/inittab and change the "3" back to a "5". Also while in gedit, find and open /etc/X11/XF86Config-4, and look for a line under...

 

Section "Device"

 

and where you see "nv", change it to "nvidia" (this time only, with the quotes just as you see them)

 

save this file, exit out of gedit, reboot, and everything should work as before except your new updated Nvidia module will be installed. If it is installed properly, from here on out all you will have to do is update your drivers which is very easy. Just become root and not in Xwindows, (and if you're online) type:

 

nvidia-installer --update [enter]

 

That's it!

Share this post


Link to post
Share on other sites

I have the download edition of Mandrake 9.2

 

Its already set to boot into the text mode, then i have to

login and type startx

 

do i need to do everythign you mentioned or is some of that null becaue it already starts in text mode?

 

 

Share this post


Link to post
Share on other sites

It's null because you are starting X by the "startx" command. Yes, you can do all of it before a startx, only you won't be able to use gedit. You'll have to use vi. Are you familiar with vi? If not, it would be easier to do startx, then go into gedit, and proceed as prescribed above.

Share this post


Link to post
Share on other sites

It ALWAYS crashes after installing the drives, some crash in the XWindows for device it said

Driver "vesa" and I chnaged that to nvidia

but it said an option below it but i cant

tell you what it is caue it crashed

and this stupid thing isnt automounting my pendrive anymore

sometimes it did that, go in as root and it would automount the drive when i plugged it in

Share this post


Link to post
Share on other sites

I guess i changed the right thing

but does linux not support 32 bit?

i get 24 bit as maximum

and oh when i start x

it shows an nvidia splash logo before

 

I guess it should be a new post but when i run update all the programs disapear from the menu, and you cant do jack, cant edit the menu or anything.

 

 

Share this post


Link to post
Share on other sites

"You did replace "nv" with "nvidia"?

 

Did you do urpmi binutils? "

 

It didnt say nv in the file

 

it said vesa (that was the previous driver)

 

so i replaced vesa with nvidia

 

 

I didnt do the binutils thing because when I reloaded the system after 5 or so times of messing misc stuff up, It never gave me that error.

 

If its working do I still need to do that bin util command?

Share this post


Link to post
Share on other sites

If you're not getting that error then I wouldn't worry about it. I just found out from this page that you also can replace "vesa" with "nvidia" rather than just "nv".

 

I love learning new things in Linux!! smile

 

So, yes, you did the right thing, and should be good to go! smile

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×