Jump to content


Photo

Setting up a Linksys Wireless-G card in SuSE 9.1 Personal Edition


  • Please log in to reply
23 replies to this topic

#1 PICKhead155

PICKhead155

    stranger

  • Members
  • 2 posts

Posted 30 June 2004 - 08:09 AM

Does anyone know how I can get a Linksys Wireless-G card working in SuSE 9.1 Personal Edition? I am a Linux novice so please explain the technical stuff. Thank you!

#2 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 30 June 2004 - 03:24 PM

Most of the cards that work with Linux are in the 802.11b class. "G" is relatively new. I have found the Linksys wireless G router is indeed backward compatible to some "b" cards but not all. I understand the Negear 511 can be made to work under Linux, but it isn't an easy process, especially for a new Linux user. I'm fairly certain the Linksys wireless G card is not yet capable of running under Linux.
Tell me about your router. Is it a Linksys wireless G? If so you may want to consider getting an Orinoco Gold Card. I know from experience it will work with "B" only routers and "G"s that are backward compatible.

#3 PICKhead155

PICKhead155

    stranger

  • Members
  • 2 posts

Posted 01 July 2004 - 05:23 AM

My router is a Linksys Wireless-G 2.4 GHz 802.11g

#4 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 01 July 2004 - 07:45 AM

Then it is compatible with the Orinoco Classic Gold card which is 802.11b. One of these cards can be had for around $49.00, check it on Froogle. Unless they've changed something, and I don't think they have, this card works with your router.

Your other choices are to try an compile a kernel for the Netgear 511 which is 802.11g, or wait and hope someone will create drivers for your Linksys.

As a matter of information: I use 802.11b on a laptop, and with 2 PCs using the Netgear MA311. All are plenty fast for me..

#5 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 11 July 2004 - 10:11 PM

a quick check of the wlan_adapters list from linux-wlan.com shows the Linksys Wireless-G
product uses a Broadcom chipset. Sorry, but there isn't an open source driver for that yet.

If you have the Linksys 802.11a/g product, then you're in better shape. It uses an
Atheros chipset.

On the other hand, if you're OK with buying software to make your Broadcom-based card
useful, take a look at DriverLoader by Linuxant. http://www.linuxant.com/driverloader/

Have a look at the 3Com 11g product (PrismGT) and the 11a/b/g product (Atheros),
part numbers 3CRWE154G72 and 3CRWE154A72, respectively.

Both are supported by either the wlan-ng or madwifi drivers included with the
2.6 kernel provided by SUSE 9.1.

You should probably get familiar and comfortable setting up a wired network to your
Linux box before you attempt setting up a wireless network.


#6 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 11 July 2004 - 11:03 PM

Martouf, those cards you mention that are in the "G" class, Suse 9.1 already has the drivers to accomodate them so you can go 802.11g? No re-compiling kernels and stuff? If so, that's really good news! smile

Do you know if 802.11g is also supported by any of the other distros using the 2.6 kernel, or is it just Suse?

Thanks!



#7 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 12 July 2004 - 06:59 PM

Yes, SUSE 9.1 includes the latest PrismGT and Atheros drivers as part of the
kernel-default package.

You'll find them in /lib/modules/2.6.4-52-default/extra

A quick check of places like kerneltraffic.org and the linux.kernel newsgroup (via Google)
indicates the linux-wlan-ng drivers were added to Debian stable, Fedora, and Slackware 10
as the version 2.6 kernel was released.

check your distro with:
find /lib/modules -name ath\*
find /lib/modules -name prism\*
find /lib/modules -name hostap\*

The best answer I can give you is "it depends" (the All Purpose Technical Answer[tm]).

I'll point out that lately there's fewer and fewer reasons to compile a kernel.
However, there's still plenty of reasons why you'll need to get the kernel source and
make all the preparations for building additional kernel modules.
('make oldconfig; make dep', that is) .. a topic for another thread, though.

#8 rogerg6ckr

rogerg6ckr

    stranger

  • Members
  • 2 posts

Posted 27 July 2004 - 03:19 AM

Hi.
Forgive me for jumping straight in.
But after a lot of googeling this is the the first thread I have seen where someone has actaully said they are running netgear MA111 devices on SuSE 9.1.
I would dearly like to know how.
Regards Roger

#9 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 27 July 2004 - 04:12 AM

Forgive me, but I'm not seeing an MA111 in this post. I see the NetGear MA311, and the NetGear 511. Which one, if either were you refering to? Or are you refering to the MA111 wireless USB? According to this, it's suppose to work.

#10 rogerg6ckr

rogerg6ckr

    stranger

  • Members
  • 2 posts

Posted 27 July 2004 - 08:25 PM

ooops sorry.
I got here from a google. I must have changed fro, searching on MA111 to somthing a little wider, And It was past bed time so the eyes were geting tired.
Thanks for the link anyway I will check it out.
Roger


#11 OldSpiceAP

OldSpiceAP

    member

  • Members
  • 134 posts

Posted 27 July 2004 - 10:01 PM

There is a free open source alternative to using the Driverloader. Its called ndiswrapper. Download the source, unzip,compile and install it. Check the readme it comes with for instructions to be certain, but I believe its :
$ make
$ make install

Then get the windows driver for your card and out it in a folder - I called mine WPC54GDRV. Make sure the .inf file is there. Then simply go to a terminal and type:
$ ndiswrapper -i /pathtodriver/drivername.inf
then type :
$ ndiswrapper -l

you should see output like this:

ndiswrapper

nameofdriver.inf present

From here simply type
$ ifconfig wlan0 up
$ iwconfig wlan0 essid any
$ dhcpcd wlan0&
& dhcpcd wlan0

Now it should be functional - type
$ iwconfig
to confirm settings - use a program like Kwifimanager to monitor signal stregnth and such.

This is sort of thing is sort of obnoxious to type every time you turn your computer on, so activate it on startup with a script.

e-mail me at brantwatson@hotmail.com if you want help with this.



#12 motaguense

motaguense

    stranger

  • Members
  • 2 posts

Posted 18 August 2004 - 07:58 AM

I have done all of the above and when i do
ifconfig wlan0 up i get:
wlan0: unknown interface: No such device


any help would be appreciated


#13 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 18 August 2004 - 04:02 PM

motaguense: OldSpiceAP provided a bunch of commands,
and not exactly in the right order.

try this:

1. configure the wlan radio (pick one of the following)

$ iwconfig wlan0 essid any
(assumes you're not using any encryption)

$ iwconfig wlan0 essid SSIDname mode managed key [1] xxxxxxxxxxxx
(if you're using WEP with a hexchar key)

2. confirm your radio has successfully linked to the AP radio

$ iwconfig wlan0
(make sure the AP addr isn't all zeroes)

3. obtain an IP addr (pick one of the following)

$ pump -i wlan0 &
(if your distro has pump)

$ dhcpcd wlan0 &
(if ...)

$ dhclient wlan0 &

(DHCP provides an IP addr and DNS config)

4. confirm your interface has an IP addr

$ ifconfig wlan0
(make sure the interface is UP and has an IP addr)

5. confirm your system has a default route

$ netstat -r
(make sure there is a 'default' route to the AP IP addr)

6. confirm your system has a DNS configuration

$ cat /etc/resolv.conf

7. enjoy!



#14 superx10

superx10

    stranger

  • Members
  • 2 posts

Posted 19 August 2004 - 04:47 AM

Hi, I'm new here (and new to using wireless in linux..actually i'm kind of new to linux itself as well..)
Anyway, I've tried everything above, but I still get a message that says the same thing as what motaguense had (wlan0: unknown interface: No such device). I got ndiswrapper all installed, and got the driver installed just fine, but everything after that doesn't seem to work at all.

I mean, my card (linksys WMP11) is set up as wlan0 (i think... :x )
but it still says it isn't there when I do iwconfig and such.

PLEASE help if you can.. i can get screenshots and that sort of thing if you need them (sorry, i just started using SuSE today, so i'm not used to setting up devices and stuff with YaST2)

#15 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 19 August 2004 - 05:24 AM

Step 0 (as root): "/sbin/modprobe ndiswrapper"

check ndiswrapper module load status with "dmesg | tail -8"



#16 OldSpiceAP

OldSpiceAP

    member

  • Members
  • 134 posts

Posted 19 August 2004 - 06:19 AM

martouf is correct - I posted the commands in the wrong order. - this may help clear things up (I also left out an important command).

First of all if you just switched to a 2.6 kernel (just in case you did ) it may be helpful to type at the command line :

$ modprobe yenya_socket

I needed this when I switched - because for some reason the pcmcia card services were not being activated at startup - this successfully activated them.

then type

$ niswrapper -M

This just does some automatic stuff in ndiswrapper - I don't know what it does exactly because mine seemed fine without it, but ndiswrapper says its needed so I always include it.

next

$ ifconfig wlan0 up

this activates the card as the systems networking device

next

$ iwconfig wlan0 essid any

substitute any with your essid if you are using some sort of encryption on you wireless connection.

$ dhcpcd wlan0&

followed by

$ dhcpcd wlan0

This obtains your ip address from the dhcpcd server.

You can roll it all into a script like this (if you want to use this just copy and paste it into a blank text document and save it as something like wlancfg. Then edit it to be executible - in kde you can actually just right click on the files icon and go to permissions and set it to executible.) - be sure you are logged in as root to do this.

start copy on the next line of text

echo "Welcome to the wlan0 configuration utility"

echo "Inserting ndiswrapper module....."

modprobe yenta_socket

modprobe ndiswrapper

echo "Activating wireless card as network device...."

ifconfig wlan0 up

echo "Setting essid..."

iwconfig wlan0 essid any

echo "Obtaining IP address via dhcp....."

dhcpcd wlan0&

dhcpcd wlan0

echo "Script completed successfully - your card should now be activated."



end copying above this line


Now place the file in your /bin file and voila - just run this from the console or shell or whatever command line interface you use and just type wlancfg (or whatever you named the script) and the rest is automatic.

Sorry about the confusion and left out commands - I was a bit tired...

P.S. I tested this on Suse 8.2 pro and 9.1 pro and on Yoper linux - it worked on all cases - and my hardware is the same as yours.

Good luck


-So Long and Thanks for All the Fish


#17 superx10

superx10

    stranger

  • Members
  • 2 posts

Posted 20 August 2004 - 03:23 AM

grr! I've tried all of the above things but it still isn't recognizing it's even there!
Does it wake a difference that i'm using wireless on a desktop computer?
Should I try re-installing Suse?
EDIT- if I do, is there a certain way I should configure my card?

ndiswrapper -l says that my driver (wmp11nds) is installed.. should I try another one? I think that there were two different drivers on my card's driver CD...

I can do everything until "ifconfig wlan0 up" ... then it says wlan0 doesnt exist. I even tried using different names other than wlan0, like sit0, eth0, eth1, etc... but nothing works..

I'm sure it's not what you guys wanna hear but if I can't get this thing to work shortly -- I'm going to need to switch back to Windows.. ;(
[Edited by superx10 on 2004-08-19 20:57:53]


#18 motaguense

motaguense

    stranger

  • Members
  • 2 posts

Posted 20 August 2004 - 06:26 AM

Martouf,
thanks for the help. I got it running...really appreciate it. One thing though is that whenever I did
> dhcpcd wlan0 &
I got an error saying

wlan0 warning: using NO encryption
ERROR: command 'iwconfig wlan0 key off' returned
Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Operation not permitted.

Still whenever I tried to connect..it worked so i guess its a dont care!

Dapper Dan,
I got the same wireless card as you and the CD I got had two different versions of .inf file. I was getting the same error as you when I was doing
ndiswrapper -i /pathtodriver/WMP11NDS.inf file
so I pointed to the other one the WMP11V27.inf file
you might want to try that






#19 martouf

martouf

    enthusiast

  • Members
  • 338 posts

Posted 20 August 2004 - 07:32 PM

you want to be sure you're choosing the NDIS 5.1 driver (.inf + .sys) to use
with ndiswrapper.

Quote:
wlan0 warning: using NO encryption
ERROR: command 'iwconfig wlan0 key off' returned
Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Operation not permitted.


means the command "iwconfig wlan0 key off" was issued at some point,
and the error message is from ndiswrapper.

I don't recall any such command in the list of commands from OldSpiceAP's
"How To" message. In any case, it's just a warning.
(you know you should be using 128bit WEP and MAC filtering, yes?)





#20 Brandon B

Brandon B

    stranger

  • Members
  • 2 posts

Posted 22 August 2004 - 10:03 AM

HI guys im new to linux and have the same wireless g card and router I have same Linux version suse 9.1 home I downloaded the source tar and extracted it to a folder "ndiswrapper-0.10" then highlight folder with mouse and right click open terminal here
the terminal appears "guy@linux:ˉ/documents/ndiswrapper-0.10>"
i want to compile and install the the module and utilitys so ive tryied make and make install and all i get is "bash : make : command not found" so i ve read thought the read me "install" in the ndis folder it says as root use the command make install so i use the command "su" and log in as root enter pass ect. so now konsole looks like this "guy@linux:ˉ/documents/ndiswrapper-0.10#" and again i try make and make install and all i get is "bash : make : command not found" so being new to linux im lost am i doing something wrong cmds or some thing i just want to get my internet going so i can stop running up and down stairs to do research on linux. Any help or suggestions are appreciated thanks.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq