Jump to content


Photo

Problem after NVidia instaallation


  • Please log in to reply
13 replies to this topic

#1 shadowmatrix

shadowmatrix

    journeyman

  • Members
  • 60 posts

Posted 22 April 2004 - 08:14 AM

I am new to Linux and have a problem. I installed the NVidia driver as instructed from there site. Also edited the inittab file as instructed. Here is the problem.
When I start the computer and try to load Linux I get sent to the command line because there was an error with the screen (no screen found) I found a way around this. Here is how. Fail Safe-->telinit 3-->logon-->startx This works without a problem. When I edited the inittab file I had to change the 5 to a 3 and then back again. I am pretty sure this is where the problem is. Can anyone provide some in sight to this? Thank you for your help.

#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 22 April 2004 - 12:51 PM

Post what distro and version of Linux that you are using, as well as which driver you used, so that we can tell what kernel etc...that you are using.

Did you install by source, or rpm? Some changes may need to be made to XFree86Config for your distro - such as changing the video driver setting from nv to nvidia, make sure that glx is loading, and so on.

#3 shadowmatrix

shadowmatrix

    journeyman

  • Members
  • 60 posts

Posted 22 April 2004 - 06:28 PM

Mandrake 10 2.6 I believe is the version. Like I said, I am very new to linux but so far I really like it. I got the driver from NVidia here it is NVIDIA-Linux-x86-1.0-5336-pkg1.mun
I edited the file and changed the nv to nvidia I dont know what else to do at this point. It would seem that maybe I should change the inittab setiing to 3 instead of 5 and it probally would boot since in order to boot i have to telinit 3 anyway. The edit instructions said to change from 5 to 3 and then back again though. Here is the xf86config-4 file

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1024x768 @ 70 Hz"
HorizSync 31.5-57.0
VertRefresh 50-70

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "NVidia"
BoardName "NVIDIA GeForce FX (generic)"
Driver "nvidia"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection




#4 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 23 April 2004 - 06:31 AM

If your /etc/inittab is set to 5 it should boot you straight to the "login manager" which is either kdm (KDE) gdm (Gnome) or xdm (unix).
If you set it to "3" it will not boot you into "X" or runlevel 5. For now, leave it at 5, unless you like to start x yourself by going:

startx [enter]

Your default color depth is set for 24 and your resolution at that depth is set for 1024x768.

If you're not getting a screen, then you may want to run as root:

XFdrake [enter]

..and play around with it until you can find a resolution and monitor configuration that works. Make sure that your monitor is listed correctly as the particular model and make you have. XFdrake takes a little while to figure out, but it has never failed me when trying to configure a monitor..

smile



#5 shadowmatrix

shadowmatrix

    journeyman

  • Members
  • 60 posts

Posted 23 April 2004 - 06:40 PM

I think I have it narrowed down to the monitor as being the problem. I don't know what the specs are on this monitor though. All I know is that it is a logisys 17 inch. I don't know what modes it supports or anything like that. I have heard that if you input the wrong settings you can fry your monitor and I sure can't afford to do that. Here is some information I get when trying to start Linux normally.

logfile/var/log/XFree86Config-4
using vt 7

(ee)NVIDIA(0): Failed to initialize the NVIDIA kernal module
(ee)NVIDIA(0): ***Aborting***
(ee)Screen(s) found, but none have a usable configuration

Fatal server error
no screens found


Once again I thank everyone for your help.

#6 shadowmatrix

shadowmatrix

    journeyman

  • Members
  • 60 posts

Posted 23 April 2004 - 07:02 PM

Thank you everyone for your help. Dapper Dan, your solution worked. I no longer get the boot error like I was. I had to change the driver for my video card to XFree nv though. I was unable to get a clean test with any configuration under XFdrake with the NVIDIA section. I also notice now that the NVIDIA splash screen is no longer showing up on boot. So if anyone has any ideas???? I suppose it's not that big of a deal. I just like knowing that everything is installed and working correctly. It's not like I will be doing any real gaming on it since everything seems to be for Windows. Or is it? If anyone could point me in the right direction for gaming that would be nice. Once again, Thankyou everyone!!!!!!!!

#7 Vermyn

Vermyn

    member

  • Members
  • 156 posts

Posted 23 April 2004 - 07:53 PM

To load the nvidia driver, you have to change the name of the driver in /etc/X11/XF86Config-4. You don't want to use the "nv" driver, that's the stock nvidia driver with no opengl acceleration.

Since you seem to have solved the inittab problem, that should mean your nvidia driver is loading into memory. Now edit your /etc/X11/XF86Config-4 and change:

Load "nv"

...to...

Load "nvidia"

Then try startx. If you get the Nvidia logo, then it's fixed. If you still don't get the Nvidia logo and X still fails to start, try "modprobe nvidia" then startx again.

If THAT works, then the nvidia module is not loading on boot and you still have to solve that before X will work.

#8 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 23 April 2004 - 10:28 PM

shadowmatrix, did you install the NVIDIA drivers from init3 or 5?

Also, if I remember correctly, you need the kernel source installed for the drivers to refer to. This may be why the true nvidia drivers are not working, Right now, you are running from the original "nv" driver, not the "nvidia" one.

Refer to the nvidia directions again on these requirements.

#9 shadowmatrix

shadowmatrix

    journeyman

  • Members
  • 60 posts

Posted 24 April 2004 - 03:30 AM

I installed the video driver from root. Not sure about the init level. I am reasonably sure it was 3. If I edit the X file to nvidia instead of nv, it fails to boot and throws me to a command prompt.
I am going to try the solutions you have provided and will post the results. Thank you

#10 shadowmatrix

shadowmatrix

    journeyman

  • Members
  • 60 posts

Posted 24 April 2004 - 03:32 AM

By the way, the installation asked me to install the source code from the Mandrake installation cd's which I did.

#11 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 24 April 2004 - 04:25 AM

From your other posts, it seems like the nvidia kernel install is failing.

If you installed from init 3, you would have been able to boot to the console only - no GUI. This is what is suggested in nvidia installation instructions, then change the level back to 5 to test the gui.

Look at the instructions and make sure that you made ALL the changes suggested to the X config file, not just the "nv" change, but the others as well.

I think that Mandrake has the drivers available through the update feature. You may want to check this out.

#12 shadowmatrix

shadowmatrix

    journeyman

  • Members
  • 60 posts

Posted 24 April 2004 - 04:53 AM

I have to agree that something went wrong in installation. I downloaded the text file for the nvidia driver and printed it out for reference before I first tryed all this. I am reasonably sure that I did everything correctly but will try again. The XFree settings were to change "nv" to "nvidia" Load "glx" and remove Load "dri and remove Load "GLcore" I was unable to find dri and glcore but did everything else. Anyway, I am going to try and do a reinstall. See you all after I get done with that.

#13 shadowmatrix

shadowmatrix

    journeyman

  • Members
  • 60 posts

Posted 24 April 2004 - 05:35 AM

Well, I replaced my XFree file with the original and replaced my inittab file with the original. Installed the driver exactly as the instructions said and edited the XFree file by changing ONLY "nv" to "nvidia" and now I am booting into init5 properly with the GUI and NVidia splash screen. Everything is working the way it should. THANKYOU EVERYONE!!!!!! YOU HAVE ALL BEEN VERY HELPFULL!!!!!!!!!!!

I hope that I will be able to return the courtesy by helping another user in need at some point in time.

#14 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 24 April 2004 - 08:50 AM

Originally posted by shadowmatrix:
Quote:
I hope that I will be able to return the courtesy by helping another user in need at some point in time.


That's the whole idea! There's an awful lot about Linux that I don't know, but if I have a little knowledge and experience with something that can help a new user, then I believe I have a responsibility to try and help them. I'm sure most here believe as I do, that helping new Linux users is a very rewarding way of giving something back to open source. I'm glad to hear you have grasped this concept so early on in your explorations with Linux! smile





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq