Jump to content


Photo

ICS on Windows XP with ZoneAlarm


  • Please log in to reply
10 replies to this topic

#1 EuriMouse

EuriMouse

    newbie

  • Members
  • 39 posts

Posted 08 December 2003 - 09:15 PM

I have version 4.5.530.000 for ZoneAlarm (it's the free one). I have the main computer with the internet connection hooked-up to one other computer that is Windows 98 and they share an internet connection fine without the ZoneAlarm firewall.

When I activate the firewall, however, the Windows 98 machine is unable to browse the internet, though I can send messages from the XP machine to the 98 one; this means then that there would be a problem with DNS, perhaps?

ZoneAlarm automatically detects the network connection, IP address and subnet mask - and I can't alter it. I have set the trusted zone security on medium, even low, so that I am absolutely sure that the trusted zone is not blocked in anyway. I have also set the network connection to be on the trusted zone and the entry type is an adapter subnet (if that is right).

Is there any way of getting the two computers to share a connection with ZoneAlarm working?

EuriMouse smile

#2 duhmez

duhmez

    addict

  • Members
  • 583 posts

Posted 09 December 2003 - 01:55 AM

last time I tried to use zonealarm, it REQUIRED you to install a special ICS client on all client machines, otherwise the ICS would not work.

This was about 1 year or so ago, I don't know if this has ever changed.
Check the FAQ's at zonealarm website see if this still needs to be done.

#3 sapiens74

sapiens74

    Pooh-Bah

  • Members
  • 1915 posts

Posted 09 December 2003 - 02:51 AM

You have to set the trusted zone settings to low

#4 Loup LeBeau

Loup LeBeau

    stranger

  • Members
  • 2 posts

Posted 09 December 2003 - 05:57 PM

Under the "Firewall" option in the program window, click the "Advanced" button. A smaller window named "Advanced Settings" will come up.

Under the "Internet Connection Sharing" section, choose the option "This computer is an ICS/NAT gateway".

That's all. You can leave your Trusted Zone setting on "Medium". Never tried it on "High", though.

#5 sapiens74

sapiens74

    Pooh-Bah

  • Members
  • 1915 posts

Posted 10 December 2003 - 02:53 AM

Leaving it at medium inteferes with some Server transactions, cause it blocks ports.

#6 EuriMouse

EuriMouse

    newbie

  • Members
  • 39 posts

Posted 10 December 2003 - 08:07 PM

Loup, the version you are referring to is one that I don't have; that is ZoneAlarm Pro. I have the standard free one. I do have the setting set to low. I have not tried installing ZA on the client computer, but I will try. Please let me know if you guys have any further suggestions!

EuriMouse smile

#7 Loup LeBeau

Loup LeBeau

    stranger

  • Members
  • 2 posts

Posted 11 December 2003 - 06:22 AM

Hm, sorry, I didn't know that option was available only in the Pro edition.

Now that the subject has been brought up, has anyone managed to use ICS with other software firewalls? That's precisely why I gave up on Sygate.

#8 ThC 129

ThC 129

    veteran

  • Members
  • 1578 posts

Posted 31 December 2003 - 06:55 AM

I have no problems with Sygate PF Pro running on my XP computer, I set the settings manually on the Windows Boxes i have used and have no problems.

Windows XP Second NIC:
IP: 192.168.0.1
Subnet: 255.255.255.0
Workgroup: Workgroup


Windows ME Primary
IP: 192.168.0.2
DNS: ISPs DNS address from running wntipcfg in Windows XP
Subnet: 255.255.255.0
Default Gateway: 192.168.0.1
Workgroup: Workgroup

Doing that setup I have no problems sharing the ISP.

#9 EuriMouse

EuriMouse

    newbie

  • Members
  • 39 posts

Posted 03 January 2004 - 06:35 PM

Even with ZoneAlarm Pro on both machines, ICS still doesn't seem to work properly. The sites have to be visited on the gateway computer for the client computer to access. And sometimes the client computer doesn't even do that... its so unstable!

EuriMouse smile

#10 EuriMouse

EuriMouse

    newbie

  • Members
  • 39 posts

Posted 26 August 2004 - 10:56 PM

My internet connection sharing worked fine and for some strange reason, I have to close the host computer's firewall for the client's internet to work. I haven't touched any settings on both machines in question - so why has it done this? Any answers?

EuriMouse smile

#11 reddy

reddy

    journeyman

  • Members
  • 1 posts

Posted 13 October 2004 - 11:18 PM

I have three computers networked using ICS to share Internet access, yet there seems to be NO software firewall compatible with XP and ICS. WHY? is there a way around this????




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq