Jump to content


Photo

How to disable dos warning messages under win 2000


  • Please log in to reply
7 replies to this topic

#1 hgr

hgr

    stranger

  • Members
  • 4 posts

Posted 31 August 2003 - 06:36 PM

Hi

I have a problem with a DOS program which launces another dos program.

I get a warning telling me that the program has tried to acces the harddisk directly and this is not allowed.

If I press close the programs ends, and if I press ignore the program continues without any problems.

So does anybody know how I can turn this warning off.

/HGR

#2 sapiens74

sapiens74

    Pooh-Bah

  • Members
  • 1915 posts

Posted 31 August 2003 - 09:46 PM

Have you tried using any command line switches?


run the exe with the /? switch and see if it has a switch to disable warnings

#3 hgr

hgr

    stranger

  • Members
  • 4 posts

Posted 31 August 2003 - 09:55 PM

It is not the DOS program that gives me the warning. IT is windows 2000, that tells me that the dos program tries to write directly to the disk, and this is not allowed.

When the dos programs is executed full screen, I dont get the warning.

STUPID WINDOWS..
I am sorry but I feel like killing Bill Gates at the moment. I have worked all day on fixing this computer, and that included a reinstall of office 2000. But NO NO NO. Office 2000 does not allow me to reinstall. I have searched the web, and found some utilitis from Microsoft that could solve the problem.

They thought rong. The only solution is to reinstall windows 2000, and every f****** application. I started this work yesterday and are back to scratch.

I Hate Microsoft, it is like every time there is a new windows released. The security updates destroyes your old system. You have to upgrade to get rid of your problems. AKSLFlaskfjlkjwretiopujklĉlkjasfĉjkl.

I am one very angry technician at the moment. Sorry. ;( ;( ;( ;( ;(

#4 sapiens74

sapiens74

    Pooh-Bah

  • Members
  • 1915 posts

Posted 01 September 2003 - 02:25 AM

Have you tried the compatibility tool?

Set it to run in a DOS environment?

#5 hgr

hgr

    stranger

  • Members
  • 4 posts

Posted 01 September 2003 - 02:30 AM

What is the compatability tool ?

I thought that was a XP feature and not win2K feature

#6 sapiens74

sapiens74

    Pooh-Bah

  • Members
  • 1915 posts

Posted 01 September 2003 - 05:37 AM

Providing you have the latest service pack, i believe its included


Right click on the shortcut, and click properties.

Then go the the compatibility tab


You can try anything from Windows 95 to Windows 2000.


It may hav DOS options too. Just try combinations to see what works

#7 hgr

hgr

    stranger

  • Members
  • 4 posts

Posted 01 September 2003 - 11:08 AM

Funny, I have the latest service pack.

I am using a win2000 servicepack 4, and have created a shortcut for the dos program on my desktop, but I dont see the compatability tab, in the properties.

Does it not work on shortcuts ?

/HGR ;(

#8 CyberGenX

CyberGenX

    addict

  • Members
  • 645 posts

Posted 01 September 2003 - 09:22 PM

Go to Start and then Run. Paste the line below in and click OK. You should then have Appcompat enabled.

regsvr32 %systemroot%\apppatch\slayerui.dll




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq