Jump to content
Compatible Support Forums
Sign in to follow this  
gilgamesh

Earthworm Jim Special Edition

Recommended Posts

I have a problem running this game on Windows XP. The game runs fine but the sound is the problem. There is no sound and all the sound settings in the game are greyed out. I have tried different compatibility layers but to no avail. Has anyone gotten this game to work? Thanks for any help in advance.

 

-gilgamesh

Share this post


Link to post
Share on other sites

I've got QFixApp settings recorded that I was using - it's been a while since I played, but as I remeber I had everything working... (if you don't have QFixApp, download the Application Compatibility Toolkit from Microsoft) Try turning on:

  • [*]DelayWinMMCallback[*]Force8BitColor[*]IgnoreMessageBox[*]Win95VersionLie[/list:u]Of course only the first one has to do with sound. Hope this helps you...

 

BTW - just to explain how I got this: WinXP comes with a fix for Earthworm Jim with the program worm.exe. My game has an executable of EWJIM3.exe, so I just copied the setting from the existing one. Then the 8 bit color one I added because I was having some weird color issues...

Share this post


Link to post
Share on other sites

I've got QFixApp settings recorded that I was using - it's been a while since I played, but as I remeber I had everything working... (if you don't have QFixApp, download the Application Compatibility Toolkit from Microsoft) Try turning on:

  • [*]DelayWinMMCallback[*]Force8BitColor[*]IgnoreMessageBox[*]Win95VersionLie[/list:u]Of course only the first one has to do with sound. Hope this helps you...

 

BTW - just to explain how I got this: WinXP comes with a fix for Earthworm Jim with the program worm.exe. My game has an executable of EWJIM3.exe, so I just copied the setting from the existing one. Then the 8 bit color one I added because I was having some weird color issues...

 

wow, have been searching for a fix for quite a long time, thank you for it...

but, could you make a little step-by-step tutorial on how to do it ?

don´t know why, but my version doesn´t have a ewjim3.exe, only a..."worm.exe" and "wormload.exe". also, i downloaded microsoft´s Application Compatibility Toolkit...but i can´t figure out how to use it -_- i pretty much suck at programming and editing things.

thank you for your time, hope you reply. can´t wait to finally play this version perfectly -_-.

Share this post


Link to post
Share on other sites

this is the first page that pops up on google for "earthworm jim special edition no sound" inquiry.

I have found yet another BUT SIMPLE solution for this old problem:

1. Launch game in win95 compatibility mode. It will allow you to enable sound.

2. Replace wail32.dll in game directory for example for THIS. It will fix instant game freeze problem when sound is enabled.

 

It works on my workstation win7 home edition 64bit. If it helped, please post this solution somewhere else so everyone will have this issue solved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×