Jump to content


Photo

I can't boot from promise ultra100 tx2 controller. WHY??


  • Please log in to reply
7 replies to this topic

#1 duhmez

duhmez

    addict

  • Members
  • 583 posts

Posted 11 April 2003 - 04:29 AM

I got my shiny new Asus A7M 266-D motherboard with dual AMD 2600+ CPU. I see no options to bot from my promise controller. there is no "Boot other device" option.

In the "other" all there is is network (int18h) or SCSI.

I tried as scsi and it did not work. I tried setting everything to disabled and no work.

How can I make the pc boot off the promise? I've booted off the promise before on my Abit, it has a "boot other divice" option that will sniff out all its buses and find a bootable parititon automatically.

If I can't bot off it I will cry, as I will lose my current installation and have to reinstall fresh. If I can make the promise boot, ten I can keep my OS intact.

Is it really possible that this shiny new motherbopard is INCAPABLE of booting from a third party IDE controller ?!?!

#2 Champion_R

Champion_R

    enthusiast

  • Members
  • 266 posts

Posted 11 April 2003 - 12:10 PM

Maybe a boot device has to be set in the RAID controllers BIOS. Then try setting the boot device as SCSI.

#3 jimf43

jimf43

    enthusiast

  • Members
  • 397 posts

Posted 11 April 2003 - 03:26 PM

Is there a jumper to enable the promise on the motherboard? Make sure it is enabled.

#4 jmmijo

jmmijo

    veteran

  • Members
  • 1550 posts

Posted 11 April 2003 - 10:11 PM

Quote:
[quote]
* I am not sure if this device of his is a RAID controller either, I was only pointing out what I have to do with my HighPoint-370 onboard motherboard firmware RAID controller... maybe his is same way, especially having to set his BIOS boot device options as his controller only (assuming it is a RAID type like mine is that is).

APK

P.S.=> Good luck there duhmez... apk

The device that duhmez is talking about is the standard UDMA or Ultra 100 ATA controller. Promise has the Fasttrak 100 which is indeed their RAID controller card.

It seems for some reason that this particular ASUS board is not recognizing this card as a SCSI device, which is what these cards are usually seen as by both the system BIOS and OS. The boot from SCSI device is what the BIOS needs to be set for. Check the Advanced settings and check what the First Boot Device is set for, make sure this is SCSI.

Also check which slot you have the Promise controller in, perhaps another PCI card is taking precedence over this card, i.e., try changing the slot that this Promise controller is installed into smile

Good luck.

#5 duhmez

duhmez

    addict

  • Members
  • 583 posts

Posted 12 April 2003 - 12:00 AM

It is not a raid card, just additional fast IDE controllers. (I have ultra100 TX2 and ultra 133tx2 installed inthe machine)

There is no options to configure it in the bios as it is not part of the motherboard, unlike the HPT 370.

On my old mobo I was booting off the promise by choosing "none" as all the boot devices, and enabling "boot other device" which will sniff all the buses and find a bootable drive automatically. (I did not choose scsi even though I believe this would have worked, it's just easier to set "boot other device enable" This is an excellent feature that I really enjoyed with my abit. (It's a VP6 BTW)

Then I just go tmy new dual board in (Finally) Installed all hardware without a hitch. I knew that I could just boot off the promie as normal and plug and play would configure the new mobo and I would not need to reinstall. ("W00T" I was thinking, glad to have the Ultra 100), makes for a way easier migration of motherboards for NT based os.

Then the hell began. No "Boot other device" option like the abit had, so I figured, no problem, I'll just set it to scsi and all will be well. It just doesn't work.

Can't boot off and retain my OS on the onboard because the AMD ide controller drivers obviously were not installed. I even tried putitn the HD back in the old machine, upgrading the via IDE drivers to the IDE (These rivers were not written, are you SURE you want to upgrade" I say yes) Then I copy AMDEIDE.SYS into my system directory and power down. Hoping the new AMD driers will be installed as my primary IDE and hoping it will boot off it when I put the HD back in the new machine. (This was especially difficult because the stupid AMD reference driver for the IDE is a %^%#^ 8 MB .exe installer, with no option to extract the files off it that I needed. I had to install a temp win2k on another oparittion then instal the AMD IDE driver so I could get at the files (Which were ~350K)

So no option I choose will allow booting from my Promise card. So I give uo and reinstall windows, configure a bunch of drivers and settings, install a bunch of crap, change admin password and create new admin acocunt. I logon as the new admin acocunt and configure a few more things. Then I reboot. Now the system will not accept my password for the new admin account or the builtin admin account. I figure SAM got corrupted. Dunno how. So I boot into dos with my snazzy Dos dual boot (bootgui=0 I learned from APK way back) and replace all the files from %windir%\repair to my system32.

This got me back going but losing all the configuration changes I had made (bout 2 hours worth.)

I hjave the second to newest mobo bios too nad the newest suports fatser cpu's, nothing mentioned about supporting IDE booting from third party controllers. I checked all over the internet to see if otherws wioth this mobo are having problems booting from third party IDE card and it seems most just install and boot from the default.

So where I am at is im booting off the onboard and I did a fresh instal of windows; million softwares, patches, Games to reinstall. (I have 300 Gig in this pc and tons and tons of software and games were setup tweaked, and installed.

Other than that, the hardware has been working well.

#6 jmmijo

jmmijo

    veteran

  • Members
  • 1550 posts

Posted 12 April 2003 - 01:22 AM

Copied and pasted from Promises website FAQ's:

288 How can I Boot from Ultra100, CMOS, SCSI, Configuration?
Cause: change the Boot Sequence in your CMOS, PCI Slot preference, Motherboard Compataibility.


Solution: There are two ways to make the Ultra100 be the bootable device. One way is to make sure there are no HDDs on the motherboard controllers. The motherboard will not find a bootable device, and allow the Ultra100 to boot. The other way is to change the Boot Sequence in your CMOS to boot from SCSI first. Since the system will see the Ultra100 as a SCSI controller, this will tell the motherboard to ignore it’s own controllers and allow our card to be the boot device. Some motherboards do not allow this, so it may not be an option for you. You MAY also be able to turn the auto-detection off on your motherboard and set all the HDDs in the CMOS to ´´None´´ or ´´Not Installed´´. This is if you have devices (other than HDDs) connected to the motherboard. Again, this last suggestion MAY work. Your motherboard may not allow this type of workaround.

Here is the link to their FAQ page for this controller, there is another page for their Ultra 133 controller as well:

http://www.promise.c...e=Ultra100 TX2#

#7 duhmez

duhmez

    addict

  • Members
  • 583 posts

Posted 12 April 2003 - 02:56 AM

The 2 IDE limit does not apply to these promise cards working, at least not for normal drive operation, I cant comment if it is causing the lack of boot. I am currently runnins the 2 promise cards and the onboard without problems.

I did try all the options listed except removing drives off the primary, and removing all cards. If I was not in such a hurry to get my new machine up and running I would have, but alas I have since reinstalled fresh and am currently doing all my post install configurations. when it comes time for a new mobo in the future, I will try these options. (I like to never ever reinstall my OS, I just ghost it and keep it ging forever. NT + ghost makes for a m,achine that need never be reinstalled most of the time. I keep my c drive @ about 1.5 gigs data on 3 gig partiiton. This ghosts to 2 cd's and I install absolutely everything else onto other drives, tempfiles, email etc all on other drives.

Thanks for the attempt at a solution here, but I have reinstalled and my old OS is deleted, and the machine is runing well still. Soon I'm gonna hit the benchmarks.......

#8 jmmijo

jmmijo

    veteran

  • Members
  • 1550 posts

Posted 12 April 2003 - 03:30 AM

I guess I'm the opposite, I like to re-install fresh and get all the devices and drivers up to date this way. With XP I just do a repair over the exisiting install and every app and setting is still there laugh




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq