Jump to content


Photo

Creative Nomad Muvo 32,64,128


  • Please log in to reply
3 replies to this topic

#1 catskul

catskul

    stranger

  • Members
  • 2 posts

Posted 26 December 2002 - 06:37 AM

I have had some fun fighting with the muvo today. (I recieived it as a Christmas present)

To sum up what I have learned:
(I AM NOT RESPONSIBLE FOR WHAT YOU DO TO YOUR MUVO. THE FOLLOWING MAY OR MAY NOT VOID YOUR WARRENTEE OR MESS IT UP)

To get it to work in Linux (in redhat 8.0 at least)
Find out which scsi device it is registered as.
Most likely it will be the default /dev/sda1 unless you have other usb or scsi devices.

Then to mount you must (with the correct sd* device)
mkdir /mnt/muvo
mount -t msdos -o rw /dev/sda1 /mnt/muvo

When you mount it you will see a file on it called settings.dat
that is just the volume setting. If you remove it nothing will happen (it will reset the volume to 12% every time you shut it off then turn it back on), but just leave it there.

Sometimes the muvo is finicky. It might refuse to turn on sometimes (im not sure why... maybe if you remove it before turning it off).
To fix this I fiddled with it by removing the battery and the file store unit in different combinations (remove both, remove one then the other, etc) along with formatting(with their windows utility) or removing all or some of the files on it.

One time It seemed not to want to turn on because I had filled it too much (why this is possible ? dont ask). It started to work after reformatting using format utility it comes with.

One other thing that happened is that I think I may have messed up the partition table by unplugging from the computer before it was done. In any case if you see the following symptoms, follow my instructions and your problem may be solved. (Warning: these instructions will delete the data on the muvo)

if:
- you know there are files on there, but the light stays red and wont play etc
- wont mount in linux nor windows.
- you get in /var/log/messages : " kernel: VFS: Can't find a valid FAT filesystem on dev 08:01."
- you get when trying to mount : "mount: wrong fs type, bad option, bad superblock on /dev/sda1,
or too many mounted file systems"
- any other problem where the muvo wont work and you know the battery is good.

then (as root):

dd if=/dev/sda1 of=/home/myhomedirectory/muvo.bak
This is a back up just in case something goes wrong.

fdisk /dev/sda1
delete the partition
create a new partition with all default values
change the partition's system id to 1 (fat12)
write partition table to disk
then put your muvo on a windows computer.
It should show up as a removable drive.
use the format utitlity that came with the muvo and reformat (not quick format)

Now it should work. (in both windows and linux)

#2 Mr Melon

Mr Melon

    stranger

  • Members
  • 1 posts

Posted 01 January 2003 - 03:15 AM

I'm having some similar problems with my 128 meg muvo.
If i'm copying mp3s to it, it'll be fine, and I'll be able to put 122 meg of mp3s on there without a problem.
I wanted a bit more music on there, so I re-encoded a bunch of songs as 64kbit wma files and tried to copy them on.. I can seem to fit only about 93 meg of wma's on here before it comes up saying the disk is full. It will usually let me create an empty text document at this point, and I kept adding to it until it was a 20 meg txt file without a problem. But if I delete this 20 meg text file and try and copy a 500k wma file on it, it'll still come up saying that the disk is full.

There are currently 63 files on the player, including settings.dat.
The player is formatted as fat16 using the utility that comes with it on the cd. Should it be formatted at fat16 or fat12?

I had the problem where the player wouldn't turn on the other day too. If I deleted all of the items from the player using windows explorer, it would show as being empty, but if I removed and plugged the drive in again, it would show up with 2 or 3 wma files that I had previously copied, but with a 0k file size. After I formatted it using the creative utility it turned on again, but it's still having these disk space problems with wma files.

#3 kva

kva

    journeyman

  • Members
  • 1 posts

Posted 09 March 2003 - 08:43 PM

With MuVo 128 one can use linux programs from
dosfstools debian package.

There is one subtility - I have had to specify FAT 12 to mkfs.vfat
to get normal transfer speed on MuVo. With FAT 16 it takes much
more time.

mkfs.vfat -F 12 /dev/sda1

If there is a problem with available space one can use
fsck.vfat -a /dev/sda1 to repair all lost clusters.

#4 dermot

dermot

    stranger

  • Members
  • 1 posts

Posted 25 June 2003 - 12:52 PM

I know that this thread is oldish, but I recently purchased a MuVo128 and felt that I should add some of my experiences as well...

Firstly, contrary to what catskul said in the first post, you should mount the device as vfat, not msdos, to enable 'proper' long name support. I found that if you mounted the device as msdos and then copied a file with a non 8.3 name to it, it wouldn't do anything when you tried to play your files. Mounting as vfat fixed that problem and removed the need to rename files during a copy.

Secondly, I've come across an issue with Gnome(2) and in particular the Trash feature. Specifically, if you are removing files from your MuVo using Nautilus, make sure that you are deleting them and not just moving them to trash. I was pulling out my hair trying to figure out why I only had five or six files on my MuVo, but seemed to only have a few megs of free space left before it finally dawned on me.

This last could also be an issue on other OSes or DEs that use a trash system.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

IPB Skin By Virteq