Jump to content


Photo

Help!!! Installed Redhat 7.1 dual boot with XP not working


  • Please log in to reply
15 replies to this topic

#1 qshakoor

qshakoor

    stranger

  • Members
  • 5 posts

Posted 20 November 2002 - 09:23 AM

I am a newbie in the Linux world. I installed Redhat (at least tried doing a dual boot) with XP. Once the computer rebooted I do not see an option to logon to XP/Dos. Any help is greatly appreciated.

I was on Windows XP (NTFS Partition).

Regards,

#2 VandhiyaThevan

VandhiyaThevan

    stranger

  • Members
  • 4 posts

Posted 20 November 2002 - 10:00 AM

If you have installed Linux after XP installation and if you have chosen the boot loader to be written in MBR, this problem may arise.

If you have chosen lilo as boot loader follow this: [You can verify this by seeing the lilo prompt while booting]
Open the /etc/lilo.conf

Add the following entries

other=/dev/hd[x][y]
label=xp

where x can be a,b,c,d and y is partition number.
For example, If u hv installed XP on Primary Master disk and on partition 2, give it as
other=/dev/hda2

close /etc/lilo.conf
and then run
lilo

It should update the boot record.

After rebooting you will be able to see xp also in the boot menu.

Regards,
VT

#3 Philipp

Philipp

    Pooh-Bah

  • Administrators
  • 1964 posts

Posted 21 November 2002 - 12:12 AM

Red Hat is using GRUB instead of LILO.

To add Windows XP to the bootmenu:
Open /etc/grub.conf (as root) in your favorite editor and add the follow:
title Windows XP
rootnoverify (hd0,0)
chainloader +1


Here an example grub.conf:
Code:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,2)
#          kernel /vmlinuz-version ro root=/dev/hda4
#          initrd /initrd-version.img
#boot=/dev/hda
default=1
timeout=10
splashimage=(hd0,2)/grub/splash.xpm.gz
title Red Hat Linux (2.4.18-4)
        root (hd0,2)
        kernel /vmlinuz-2.4.18-4 ro root=/dev/hda4 hdd=ide-scsi
        initrd /initrd-2.4.18-4.img
title Windows XP
        rootnoverify (hd0,0)
        chainloader +1


#4 qshakoor

qshakoor

    stranger

  • Members
  • 5 posts

Posted 21 November 2002 - 01:09 AM

Actually you get an option to use Grub or Lilo. I had gone with Lilo. I modified the Lilo script but it still doesn't seem to give me an option to boot to XP.

Here is what my lilo.conf file looks like ->

boot=/dev/hda7
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
lba32
default=linux

image=/boot/vmlinuz-2.4.2-2
label=linux
read-only
root=/dev/hda8
other=/dev/hda1
label=xp
append="hdc=ide-scsi"

Appreciate your response.

Regards,

Asim

#5 punkisdead

punkisdead

    member

  • Members
  • 118 posts

Posted 21 November 2002 - 03:58 AM

well the second half of your lilo.conf is all screwy

it should read as follows:

image=/boot/vmlinuz-2.4.2-2
label=linux
root=/dev/hda8
append="hdc=ide-scsi"

other=/dev/hda1
label=xp


then after you have fixed the lilo.conf you then need to run lilo again to make the changes go into effect.

#6 qshakoor

qshakoor

    stranger

  • Members
  • 5 posts

Posted 29 November 2002 - 03:24 AM

Hey Guys,

Thanks for all your help. I tried changing the lilo.conf file but that didn't seem to help me either. I guess I might have screwed up somewhere in the install. I went ahead and fixed my Windows XP by fixing the MBR. Once I was able to boot back to XP, I killed the Linux partitions. I decided then it is not the time for me to get into Linux. Funny thing is I heard that Redhat 8.0 is out smile Last night I tried doing a dual boot with Red Hat 8.0, and it worked like a charm. With 7.1 I was not able to fix my video config whereas 8.0 had the right drivers smile Hooooah!!!

I am now trying to figure out Linux smile Is there something similar to .profile (Unix uses this for setting up environment I believe)?

Appreciate your help.

Asim

#7 codfish

codfish

    stranger

  • Members
  • 3 posts

Posted 27 January 2005 - 04:35 PM

Hi, this is a slight thread hijack, although it may help others in my situation.

I had made my Laptop dual boot with Fedora 9 and XP.

It loaded up into either one, with WIndows as my default.

I was using Grub Boot Loader.

I have now given up on using Unix as it took ages to get the resolution right for my computer, and then I realised I was going to have to track down all the driver files for all the hardware and it just seemed like too much trouble, no wonder Windows is so popular.

Anyway, as I now only have Windows on the system, I no longer want to open up into Grub and then wait 30 seconds before the OS loads, so how do I delete the Grub Boot Loader?

Thanks for your help.

#8 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 28 January 2005 - 12:05 AM

Do you have your Windows XP installation disk?

If so, set the cd as the first boot option in the bios and do the following;

Restoring the MBR of Windows XP

Boot from the Windows XP CD and press the R key during the setup to start the recovery console. Select your Windows XP installation from the list and enter the administrator password. At the input prompt, enter the command FIXMBR and confirm with y when asked to do so. Then reboot the computer with exit.



#9 codfish

codfish

    stranger

  • Members
  • 3 posts

Posted 29 January 2005 - 09:36 AM

No, as XP was already installed, all I have is a reset to factory settings disk, (probably a Ghost disk), so this isn't an option.

Is there no way just to disable Grub and delete the files?, reverting to the 'normal' Windows OS loader?

#10 shobhit

shobhit

    stranger

  • Members
  • 19 posts

Posted 29 January 2005 - 12:29 PM

if you are using grub then you can simply edit your /etc/grub.conf file, in the line containing timeout there will be 30 for your system, you can set it smaller values, as you wish.

if you set it to zero then remember you will not be able to boot into linux after that.

#11 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 29 January 2005 - 12:57 PM

I'm not surprised that RedHat 9 did not work, especially if this is a newer laptop.

Quote:
Anyway, as I now only have Windows on the system, I no longer want to open up into Grub and then wait 30 seconds before the OS loads, so how do I delete the Grub Boot Loader?


It looks like you no longer have RedHat 9 on your system? Did you delete the partition?

If you did not, it would be relatively easy to remove grub, but you need to have an alternate plan.

The amount of time that it takes Windows to load really has nothing to do with grub, which just points to windows on the hard drive.

Anyway, you are in an interesting position. No Windows CD (I hate how laptop companies do this. You should have the Windows cd).

The first thing that I would do is back-up and important data.

The fix would be to restore the Master Boot Record. You can't see it and there are no files that you can remove.

If you really insist that you want grub off the system, you can use a Windows 98 boot disk to restore the MBR to windows only. There is some risk that this will not work and make the system unbootable. So consider this carefully.

Anyway, get a Windows 98 boot disk from bootdisk.com.

Boot from the floppy and go to the c: drive.

Type in fdisk /mbr and hit the enter key.

Again, make sure that you back up your data first and that your system recovery cd disks are at hand.

I hope that the recovery disks also restore Windows, if you need to re-install? If you don't know, consult your laptop manufacturer's web site or support before doing anything.

#12 u_r_a_windroid

u_r_a_windroid

    stranger

  • Members
  • 6 posts

Posted 29 January 2005 - 03:08 PM

"It looks like you no longer have RedHat 9 on your system?"

One of us needs glasses because I could swear the title of the post says 7.1. By the way, gshakoor, there are much less 'glitchy' (and better) distros out there than Red Hat. Just ask one of these 'experts'.

Question for the website people: if you can have a lightbulb or floppydisk icon up there, why is there no penguin? frown

#13 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 29 January 2005 - 05:34 PM

Originally posted by u_r_a_windroid:
Quote:
"It looks like you no longer have RedHat 9 on your system?"One of us needs glasses because I could swear the title of the post says 7.1.

codfish said Fedora 9. Since there is no such version of Fedora, danleff assumed he meant RedHat 9.

Quote:
By the way, gshakoor, there are much less 'glitchy' (and better) distros out there than Red Hat.

Then why don't you recommend one?

Quote:
Just ask one of these 'experts'.

Not one member here, (who, unlike you, have actually taken the time to make constuctive posts to help others), has ever referred to themselves as an expert.

Quote:
Question for the website people: if you can have a lightbulb or floppydisk icon up there, why is there no penguin?

Because none of us here need it. Do you?

u_r_a_windroid, in your very first post at Linuxcompatible, all you have done is gripe and complain. You have made no effort to help anyone with a problem. You're really out to make a good impression aren't you? If you can't offer constructive help or ask for assistance in a polite way, then please don't post at all. We were doing just fine before you got here will do fine long after you leave.
[Edited by Dapper Dan on 2005-01-29 10:12:53]


#14 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 30 January 2005 - 02:45 PM

u_r_a_windroid, look again! Yes, the title of the thread, from 2 years ago (2002), was redhat 7.1, but codfish's post is recent (1/27/05). Codfish tagged this thread, but the original POST was not his!

shobhit, good point. but, it is unclear if he can still access his linux install. I'm glad you pointed this out. You can change the delay to boot to anything that you want. When you are at the Grub boot screen just choose any entry and hit the enter key and this will override the delay, including the first entry.

#15 codfish

codfish

    stranger

  • Members
  • 3 posts

Posted 30 January 2005 - 04:03 PM

OK, firstly, thank you to all those offering helpful advice.

Secondly, I apologise for the thread hijack, as it was bound to cause confusion, but as I was searching the forum for info, this is the threaed that seemed most relevant, so I thought tagging this onto the end might melp others in my situation.

I presume that as I can now only boot into Windows, that editing the Grub.conf file is no longer an option?

I don't really want to do anything too drastic as the system is basically stable as regards boot-up, it is just a bit annoying to have to wait while grub counts down.

I do have access to an ISO of Mandrake Move, so presumably I need to burn this to CD, boot into Linux and then edit Grub, is this correct?, and yes I have deleted the Linux partition and reassigned that space to other partitions, have I basically burnt my boat regarding editing Grub.conf?

I am running XP, so is the 98 disk really the one I want?

Thanks again.

#16 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 30 January 2005 - 05:03 PM

No need to apoligize, you did nothing wrong. You did not hijack the thread. Your post explained your situation fine.

Personally, I would leave the system alone, if it is functioning properly and you feel queasy about changing anything right now.

To offset the delay of Win XP booting, just highlight it and hit the enter key. The 30 second boot delay will be be skipped. There is no delay, no countdown, and Windows will boot immediately.

If you have already changed the previous install partition for RedHat and it is no longer there, the grub menu.lst file may not be there. There is nothing to change, in this case.

If you boot a live cd and know where the partition is (say it is still there and the /boot/grub/menu.lst file is still present), then you can edit it to make changes, but not delete Grub from the master boot record itself, which resides on the first part of your master ide drive.

The problem is that you don't have a Win XP cd disk to run the recovery of the MBR to Windows.

In this case, you need to resort to more drastic measures, hence my post on the Win 98 boot disk and the the command line to try and re-write the MBR. Some report this works, some report that it fails. I believe this is due to the way the system was already set up.

If this is an HP or Compaq system, I would leave it alone. these systems are a little tricky, as they often have recovery and bios related information on a small hidden partition at the beginning of the master hard drive.

To get an idea of what we mean, do a search on Windows XP restore MBR and you will come across some examples of what I mean.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq