Jump to content
Compatible Support Forums
Sign in to follow this  
casimir

A7N8X-E Deluxe + Slackware Gigabit ethernet problems

Recommended Posts

I know that a someone has posted there sound based problem with there A7N8X Deluxe, but I am having problem with the -E version; My gigabit (and the 10/100 port) are not working. When I looked at ifconfig, I only saw the "lo" device. I have looked around for info/drivers and have only come up with a kernel patch for the 2.4.23 or 2.6.0 (my slackware install ses the 2.4.22 kernel). As I was writing this I did some more research on the 2.6 kernel and found out that it has capabilities to use the marvell LAN driver as a kernel patch (I think). I don't know much about this so it is all confusing. How can I get my gigabit working?

 

 

I am going to try to upgrade my kernel to 2.6.3 and see if it works then. I can't find a driver(or kernel patch, or what ever it is) for the 2.6.3 kernel. Will I have to use the 2.6.0 (or 2.4.23 because they have a driver for it) kernel to use my gigabit?

 

Thank you for the help.

Share this post


Link to post
Share on other sites

Be careful with the kernel upgrade. If you have experience with the 2.6.0 kernel and compiling the drivers/options in the kernel, as well as the package dependencies, good luck and let us know how it works.

 

But, before you do all that, if this board has the nForce chipset, why not install the NVIDIA drivers first and see if this fixes the problems?

 

See this discussion;

 

http://www.linuxquestions.org/hcl/showproduct.php?product=70

 

as well as this one...

 

http://linuxquestions.org/questions/history/140154

Share this post


Link to post
Share on other sites

thank you for the advice danleff. I have not totally solved the problem, but I am on my way to doing so. I put in a pci NIC so I could d/l the nvidia drivers. And it wouldn't work. It says it was timing out trying to get a dhcp reply. So I gave it the command "dhcpcd" and it worked. maybe dhcpcd has a longet timeout time?? I will post the results on monday. Hopefully by then I am gigabit enabled.

laugh

THanks

Share this post


Link to post
Share on other sites

Hi casimir you solved the problem with asus a7n8x-e dlx lan in slackware 9.1? i have the same problem and i go to the nvidia site and download the nforce drives an install in slackware but the lan still not working.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×