Jump to content


Photo

A7N8X Deluxe (nforce2) + Fedora + KDE 3.2 = No Sound


  • Please log in to reply
8 replies to this topic

#1 weeb

weeb

    stranger

  • Members
  • 12 posts

Posted 18 February 2004 - 01:21 PM

Hi All,

I know there are countless posts along the same lines but none seem to quite do the job.

I installed fedora, I got prompted to check the sound and it worked fine, I installed the unified nvidia nforce driver.

I then did a full 'yum' update to get the latest everything, including kernel (2.4.22-1.2166).

Then I installed kde 3.2, loged in to that and I got an arts error saying:

Sound Server Informational Message: Error while init the
sound driver can't start sound i/o The sound
server will continue, using the Null output Device.

I've already tried installing the alsa drivers (v1.02) but still the same message. after some hunting around I found a sight that mentiond turning off artsd by going in to the control panel and turning off artsd...it just is not an option in kde 3.2 as far as I can see...!

does anyone have a comprehensive answer to this because I think you would make a lot of people (especially me) very happy!

#2 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 19 February 2004 - 12:30 AM

You may help me out with this one. It seems to be a KDE 3.2 issue. Same thing happened to me when I installed KDE 3.2 in Debian. Got to be a KDE issue.

What happens when you login to root? Does the sound work w/o the message?

By the way, how did you install kDE 3.2? Via the console or is there an apt/yum repository?

#3 weeb

weeb

    stranger

  • Members
  • 12 posts

Posted 19 February 2004 - 12:57 PM

I get the same result even if I log in as root...

as for the setup, I installed it (from new, not upgrade) using this

http://fedoranews.or...utorial/kde3.2/

I needed to sort out a couple of dependencies but not many and it worked a treat. There are also details about how to get it working with YUM

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 19 February 2004 - 01:29 PM

Thanks for the link!

The answer has to be on the tip of my mind. Can you still boot to the older kernel, and if so, do you get the same message?

What I am thinking is that it may have been the kernel upgrade and the addition or absence of headers for the kernel version, although the modules et al should have been added during the kernel upgrade process.

Now that I thnk of it, I may have done the same thing. The ideal would be to know if the sound disappeared after the kernel upgrade or the KDE upgrade.

It would be a shame if you have to re-install the NVIDIA drivers after the kernel upgrade.

One more thought. Did you do the install from a console window or Gnome, or though the old KDE?

#5 weeb

weeb

    stranger

  • Members
  • 12 posts

Posted 19 February 2004 - 07:51 PM

I can still boot to the older kernel and I get the same problem....

I installed it from a terminal within gnome...it said not to do it in kde which I can understand.

I know it's a bit drastic but I'm going to start from scratch tonight, it's a fairly new install anyway so I won't really be losing anything and I'll see if I can get it working with the original kernel (2.4.22-1.2115).

I'll just try and install it without any kde and see how I get on.

#6 weeb

weeb

    stranger

  • Members
  • 12 posts

Posted 19 February 2004 - 09:44 PM

OH MY GOD!

when in gnome i went to check the sound levels and right clicked the sound applet and selected preferences, all I could see was microphone....hmmmmm

after a bit of head scratching I got it...I've got a web cam (with built in mike) plugged in on the usb port and this was being recognised as the main aduio device for my system. after unplugging it, guess what...the audio worked!

I'm about to update the kernel and install kde 3.2 so I'll soon see if that was it...I can't believe it chose that over the nforce2.

so the question now is, how can you have them both connected and select the main audio device?

#7 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 20 February 2004 - 12:21 AM

First of all, nice troubleshooting!

Secondly, I'm sure there is a way to set the default. I'll have to look and see where it is. The possible issue is where KDE 3.2 placed the sound config utility and where it is now in the menu system.

Before I upgrade, I'll look around and try to find it.

#8 weeb

weeb

    stranger

  • Members
  • 12 posts

Posted 20 February 2004 - 03:37 AM

Now we are getting somewhere...

I updated the kernel (kernel-2.4.22-1.2174) installed kde 3.2 and everything is working fine! laugh

I've got xine working with dvds / mp3s. xmms doesn't seem to want to play but I'll have another go later...

Still can't find an appropriate sound config util though but to be honest my webcam mainly serves the purpose of sittng on my monitor and not much else, sure it would be nice to have it working but it really isn't necessary.

#9 nleco

nleco

    stranger

  • Members
  • 2 posts

Posted 07 July 2004 - 04:20 AM

I also have a similar problem... I have the current fedora kernel... and a logitech camera... it's detecting the microphone as my sound card? how do I change this???

i have the same motherboard... Asus A7N8X Deluxe... I believe I use the default desktop, which i believe is Gnome (because it has a little footprint in the lower left...

thank you.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq