Jump to content


Photo

XP and Linux problem! Need help here...


  • Please log in to reply
9 replies to this topic

#1 munzer

munzer

    stranger

  • Members
  • 18 posts

Posted 12 February 2004 - 12:23 AM

guys... i have a 40 GB, with 2 partitions... the 30 is for the XP and the 10 is for linux... after I finish installing the linux it automatically boots to XP without asking or any thing... how can i solve this problem...

#2 LnxAddct

LnxAddct

    stranger

  • Members
  • 18 posts

Posted 12 February 2004 - 02:42 AM

When installing Fedora, did you choose to not install the boot loader? If so then that is your problem. It could be some other issues, so if this isn't the case then jsut let me know.
Regards,
Steve

#3 munzer

munzer

    stranger

  • Members
  • 18 posts

Posted 12 February 2004 - 02:49 AM

Quote:
When installing Fedora, did you choose to not install the boot loader? If so then that is your problem. It could be some other issues, so if this isn't the case then jsut let me know.
Regards,
Steve

i didn't install fedora... i installed redhat linux 9.0

#4 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 12 February 2004 - 02:52 AM

During the install, did you install a bootloader, or choose to make a floppy boot disk?

#5 munzer

munzer

    stranger

  • Members
  • 18 posts

Posted 12 February 2004 - 02:54 AM

Quote:
During the install, did you install a bootloader, or choose to make a floppy boot disk?

nah mate... i didn't anywayz... where can i do that? while intalling...

#6 danleff

danleff

    Carpal Tunnel

  • Moderators
  • 2903 posts

Posted 12 February 2004 - 04:44 AM

If my memory serves me correctly, during the install, you should have been given the option to install grub or lilo as a bootloader. You may have been discouraged from doing so with a warning that if you had another OS on the system, to do "nothing."

Of course, if you also elected not to make a boot disk, or install the bootloader, then there is no way to boot Linux as the master boot record is not overwritten with lilo or grub.

So, there is no way to boot the distro, unless you have another linus system and add the appropriate entires to lilo or grub.

DapperDan uses RedHat and may be able to give you some guidance in this area. There may be a boot disk image file on the first CD that will work.

#7 LnxAddct

LnxAddct

    stranger

  • Members
  • 18 posts

Posted 12 February 2004 - 05:42 AM

I believe if you insert the first fedora or redhat cd you can "Repair" the install, during that it should ask you to install the boot loader, I've never had to, but it should ask you to so give that a shot. RedHat will detect that you also have windows installed and will set up both for you (well I know Fedora did for me so I assume RedHat 9 will)
Regards,
Steve

#8 Dapper Dan

Dapper Dan

    Pooh-Bah

  • Moderators
  • 1703 posts

Posted 12 February 2004 - 06:01 AM

I've never tried that but I think you're on the right track. Couldn't he just run the install again, only this time as an upgrade rather than a full install and it'll still give him the opportunity to create a grub bootloader and boot disk?

#9 LnxAddct

LnxAddct

    stranger

  • Members
  • 18 posts

Posted 12 February 2004 - 09:27 AM

Yea something along those lines should be the answer. I guess we'll have to wait until munzer gets back to us to see if it worked out ok.
Regards,
Steve

#10 Maillion

Maillion

    enthusiast

  • Members
  • 213 posts

Posted 12 February 2004 - 08:25 PM

He could also use LoadLin from DOS... It still exists, and is up top version 1.6. (I was a little boared last night, so I was surfing. I found a site that gives a step by step technique to make a windows shortcut on the desktop.) Hey, I try to learn something every day, even if I have no real use for it...8)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq