Jump to content
Compatible Support Forums
Sign in to follow this  
pablovschby

kernel 2.6.1: iptables doesn't work

Recommended Posts

I've baked my own new 2.6.1-kernel for my redhat9 and the most functions run well (like usb&rpm's...). But I've got the following problem with loading and acting iptables. I've compiled "iptables" as a modul in my kernel:

Code:
# IP: Netfilter Configuration## CONFIG_IP_NF_CONNTRACK is not set# CONFIG_IP_NF_QUEUE is not setCONFIG_IP_NF_IPTABLES=mCONFIG_IP_NF_MATCH_LIMIT=mCONFIG_IP_NF_MATCH_IPRANGE=mCONFIG_IP_NF_MATCH_MAC=mCONFIG_IP_NF_MATCH_PKTTYPE=mCONFIG_IP_NF_MATCH_MARK=mCONFIG_IP_NF_MATCH_MULTIPORT=mCONFIG_IP_NF_MATCH_TOS=mCONFIG_IP_NF_MATCH_RECENT=mCONFIG_IP_NF_MATCH_ECN=mCONFIG_IP_NF_MATCH_DSCP=mCONFIG_IP_NF_MATCH_AH_ESP=mCONFIG_IP_NF_MATCH_LENGTH=mCONFIG_IP_NF_MATCH_TTL=mCONFIG_IP_NF_MATCH_TCPMSS=mCONFIG_IP_NF_MATCH_OWNER=mCONFIG_IP_NF_MATCH_PHYSDEV=mCONFIG_IP_NF_FILTER=mCONFIG_IP_NF_TARGET_REJECT=m# CONFIG_IP_NF_MANGLE is not setCONFIG_IP_NF_TARGET_LOG=mCONFIG_IP_NF_TARGET_ULOG=mCONFIG_IP_NF_TARGET_TCPMSS=mCONFIG_IP_NF_ARPTABLES=yCONFIG_IP_NF_ARPFILTER=yCONFIG_IP_NF_ARP_MANGLE=y# CONFIG_IP_NF_COMPAT_IPCHAINS is not set# CONFIG_IP_NF_COMPAT_IPFWADM is not set## DECnet: Netfilter Configuration## CONFIG_DECNET_NF_GRABULATOR is not set## Bridge: Netfilter Configuration## CONFIG_BRIDGE_NF_EBTABLES is not setCONFIG_XFRM=y# CONFIG_XFRM_USER is not set
do you see.... i also can load the module:(?)---...hmmm:
Code:
[root@mobile_abc1 scripts]# modprobe iptablesFATAL: Module iptables not found.[root@mobile_abc1 scripts]# modprobe ip_tables[root@mobile_abc1 scripts]# lsmodModule                  Size  Used byip_tables              20240  0autofs                 15488  0ds                     14720  0pcmcia_core            63616  1 dsohci1394               34816  0ieee1394               79244  1 ohci1394parport_pc             27016  0parport                42560  1 parport_pcide_scsi               14980  0usbmouse                5760  0usbkbd                  7424  0hid                    64000  0
but anyhow, i can't use and act iptables:
Code:
[root@mobile_abc1 scripts]# ./MASTERCHAINSFilterregeln des MASTERCHAINS werden ├╝bernommen...iptables v1.2.7a: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)Perhaps iptables or your kernel needs to be upgraded.iptables v1.2.7a: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)Perhaps iptables or your kernel needs to be upgraded.iptables v1.2.7a: can't initialize ip--...[b]usw, usw[/b]
but why? has got anyone of you an idea, why it isn't running...? the module is loaded as you see above by the command "lsmod"...

regards&thanks

pablo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×