Jump to content
Compatible Support Forums
Sign in to follow this  
news

[security-announce] openSUSE-SU-2017:2186-1: important: Security update for openjpeg2

Recommended Posts

openSUSE Security Update: Security update for openjpeg2

______________________________________________________________________________

 

Announcement ID: openSUSE-SU-2017:2186-1

Rating: important

References: #979907 #997857

Cross-References: CVE-2015-8871 CVE-2016-7163

Affected Products:

openSUSE Leap 42.3

openSUSE Leap 42.2

______________________________________________________________________________

 

An update that fixes two vulnerabilities is now available.

 

Description:

 

This update for openjpeg2 fixes the following issues:

 

- CVE 2016-7163: Integer Overflow could lead to remote code execution

(bsc#997857)

- CVE 2015-8871: Use-after-free in opj_j2k_write_mco function could lead

to denial of service (bsc#979907)

 

This update was imported from the SUSE:SLE-12-SP2:Update update project.

 

 

Patch Instructions:

 

To install this openSUSE Security Update use YaST online_update.

Alternatively you can run the command listed for your product:

 

- openSUSE Leap 42.3:

 

zypper in -t patch openSUSE-2017-943=1

 

- openSUSE Leap 42.2:

 

zypper in -t patch openSUSE-2017-943=1

 

To bring your system up-to-date, use "zypper patch".

 

 

Package List:

 

- openSUSE Leap 42.3 (i586 x86_64):

 

libopenjp2-7-2.1.0-16.1

libopenjp2-7-debuginfo-2.1.0-16.1

openjpeg2-2.1.0-16.1

openjpeg2-debuginfo-2.1.0-16.1

openjpeg2-debugsource-2.1.0-16.1

openjpeg2-devel-2.1.0-16.1

 

- openSUSE Leap 42.3 (x86_64):

 

libopenjp2-7-32bit-2.1.0-16.1

libopenjp2-7-debuginfo-32bit-2.1.0-16.1

 

- openSUSE Leap 42.2 (i586 x86_64):

 

libopenjp2-7-2.1.0-13.3.1

libopenjp2-7-debuginfo-2.1.0-13.3.1

openjpeg2-2.1.0-13.3.1

openjpeg2-debuginfo-2.1.0-13.3.1

openjpeg2-debugsource-2.1.0-13.3.1

openjpeg2-devel-2.1.0-13.3.1

 

- openSUSE Leap 42.2 (x86_64):

 

libopenjp2-7-32bit-2.1.0-13.3.1

libopenjp2-7-debuginfo-32bit-2.1.0-13.3.1

 

 

References:

 

https://www.suse.com/security/cve/CVE-2015-8871.html

https://www.suse.com/security/cve/CVE-2016-7163.html

https://bugzilla.suse.com/979907

https://bugzilla.suse.com/997857

 

--

To unsubscribe, e-mail: opensuse-security-announce+unsubscribe ( -at -) opensuse.org

For additional commands, e-mail: opensuse-security-announce+help ( -at -) opensuse.org

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×