Jump to content


Photo

[security-announce] openSUSE-SU-2017:2155-1: important: Security update for tcmu-runner


  • Please log in to reply
No replies to this topic

#1 News

News

    stranger

  • Members
  • 80801 posts

Posted 12 August 2017 - 01:10 AM

openSUSE Security Update: Security update for tcmu-runner
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:2155-1
Rating: important
References: #1049485 #1049488 #1049489 #1049490 #1049491

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that contains security fixes can now be installed.

Description:

This update for tcmu-runner fixes the following issues:

- qcow handler opens up an information leak via the CheckConfig D-Bus
method (bsc#1049491)
- glfs handler allows local DoS via crafted CheckConfig strings
(bsc#1049485)
- UnregisterHandler dbus method in tcmu-runner daemon for non-existing
handler causes denial of service (bsc#1049488)
- UnregisterHandler D-Bus method in tcmu-runner daemon for internal
handler causes denial of service (bsc#1049489)
- Memory leaks can be triggered in tcmu-runner daemon by calling D-Bus
method for (Un)RegisterHandler (bsc#1049490)

This update was imported from the SUSE:SLE-12-SP3:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-919=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libtcmu-devel-1.2.0-3.1
libtcmu1-1.2.0-3.1
libtcmu1-debuginfo-1.2.0-3.1
tcmu-runner-1.2.0-3.1
tcmu-runner-debuginfo-1.2.0-3.1
tcmu-runner-debugsource-1.2.0-3.1
tcmu-runner-devel-1.2.0-3.1

- openSUSE Leap 42.3 (x86_64):

tcmu-runner-handler-rbd-1.2.0-3.1
tcmu-runner-handler-rbd-debuginfo-1.2.0-3.1


References:

https://bugzilla.suse.com/1049485
https://bugzilla.suse.com/1049488
https://bugzilla.suse.com/1049489
https://bugzilla.suse.com/1049490
https://bugzilla.suse.com/1049491

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe ( -at -) opensuse.org
For additional commands, e-mail: opensuse-security-announce+help ( -at -) opensuse.org







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq