Jump to content
Compatible Support Forums
Sign in to follow this  
news

[security-announce] openSUSE-SU-2017:1882-1: important: Recommended update for ncurses

Recommended Posts

openSUSE Security Update: Recommended update for ncurses

______________________________________________________________________________

 

Announcement ID: openSUSE-SU-2017:1882-1

Rating: important

References: #1000662 #1046853 #1046858

Cross-References: CVE-2017-10684 CVE-2017-10685

Affected Products:

openSUSE Leap 42.2

______________________________________________________________________________

 

An update that solves two vulnerabilities and has one

errata is now available.

 

Description:

 

This update for ncurses fixes the following issues:

 

Security issues fixed:

- CVE-2017-10684: Possible RCE via stack-based buffer overflow in the

fmt_entry function. (bsc#1046858)

- CVE-2017-10685: Possible RCE with format string vulnerability in the

fmt_entry function. (bsc#1046853)

 

Bugfixes:

- Drop patch ncurses-5.9-environment.dif as YaST2 ncurses GUI does not

need it anymore and as well as it causes bug bsc#1000662

 

This update was imported from the SUSE:SLE-12:Update update project.

 

 

Patch Instructions:

 

To install this openSUSE Security Update use YaST online_update.

Alternatively you can run the command listed for your product:

 

- openSUSE Leap 42.2:

 

zypper in -t patch openSUSE-2017-823=1

 

To bring your system up-to-date, use "zypper patch".

 

 

Package List:

 

- openSUSE Leap 42.2 (i586 x86_64):

 

libncurses5-5.9-55.3.1

libncurses5-debuginfo-5.9-55.3.1

libncurses6-5.9-55.3.1

libncurses6-debuginfo-5.9-55.3.1

ncurses-debugsource-5.9-55.3.1

ncurses-devel-5.9-55.3.1

ncurses-devel-debuginfo-5.9-55.3.1

ncurses-utils-5.9-55.3.1

ncurses-utils-debuginfo-5.9-55.3.1

tack-5.9-55.3.1

tack-debuginfo-5.9-55.3.1

terminfo-5.9-55.3.1

terminfo-base-5.9-55.3.1

 

- openSUSE Leap 42.2 (x86_64):

 

libncurses5-32bit-5.9-55.3.1

libncurses5-debuginfo-32bit-5.9-55.3.1

libncurses6-32bit-5.9-55.3.1

libncurses6-debuginfo-32bit-5.9-55.3.1

ncurses-devel-32bit-5.9-55.3.1

ncurses-devel-debuginfo-32bit-5.9-55.3.1

 

 

References:

 

https://www.suse.com/security/cve/CVE-2017-10684.html

https://www.suse.com/security/cve/CVE-2017-10685.html

https://bugzilla.suse.com/1000662

https://bugzilla.suse.com/1046853

https://bugzilla.suse.com/1046858

 

--

To unsubscribe, e-mail: opensuse-security-announce+unsubscribe ( -at -) opensuse.org

For additional commands, e-mail: opensuse-security-announce+help ( -at -) opensuse.org

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×