Jump to content
Compatible Support Forums
Sign in to follow this  
news

[security-announce] openSUSE-SU-2017:0107-1: important: Security update for flash-player

Recommended Posts

openSUSE Security Update: Security update for flash-player

______________________________________________________________________________

 

Announcement ID: openSUSE-SU-2017:0107-1

Rating: important

References: #1019129

Cross-References: CVE-2017-2925 CVE-2017-2926 CVE-2017-2927

CVE-2017-2928 CVE-2017-2930 CVE-2017-2931

CVE-2017-2932 CVE-2017-2933 CVE-2017-2934

CVE-2017-2935 CVE-2017-2936 CVE-2017-2937

CVE-2017-2938

Affected Products:

openSUSE 13.2 NonFree

______________________________________________________________________________

 

An update that fixes 13 vulnerabilities is now available.

 

Description:

 

This update to Adobe Flash 24.0.0.194 fixes the following vulnerabilities

advised under APSB17-02:

 

- security bypass vulnerability that could lead to information disclosure

(CVE-2017-2938)

- use-after-free vulnerabilities that could lead to code execution

(CVE-2017-2932, CVE-2017-2936, CVE-2017-2937)

- heap buffer overflow vulnerabilities that could lead to code execution

(CVE-2017-2927, CVE-2017-2933, CVE-2017-2934, CVE-2017-2935)

- memory corruption vulnerabilities that could lead to code execution

(CVE-2017-2925, CVE-2017-2926, CVE-2017-2928, CVE-2017-2930,

CVE-2017-2931)

 

 

Patch Instructions:

 

To install this openSUSE Security Update use YaST online_update.

Alternatively you can run the command listed for your product:

 

- openSUSE 13.2 NonFree:

 

zypper in -t patch openSUSE-2017-71=1

 

To bring your system up-to-date, use "zypper patch".

 

 

Package List:

 

- openSUSE 13.2 NonFree (i586 x86_64):

 

flash-player-24.0.0.194-2.124.1

flash-player-gnome-24.0.0.194-2.124.1

flash-player-kde4-24.0.0.194-2.124.1

 

 

References:

 

https://www.suse.com/security/cve/CVE-2017-2925.html

https://www.suse.com/security/cve/CVE-2017-2926.html

https://www.suse.com/security/cve/CVE-2017-2927.html

https://www.suse.com/security/cve/CVE-2017-2928.html

https://www.suse.com/security/cve/CVE-2017-2930.html

https://www.suse.com/security/cve/CVE-2017-2931.html

https://www.suse.com/security/cve/CVE-2017-2932.html

https://www.suse.com/security/cve/CVE-2017-2933.html

https://www.suse.com/security/cve/CVE-2017-2934.html

https://www.suse.com/security/cve/CVE-2017-2935.html

https://www.suse.com/security/cve/CVE-2017-2936.html

https://www.suse.com/security/cve/CVE-2017-2937.html

https://www.suse.com/security/cve/CVE-2017-2938.html

https://bugzilla.suse.com/1019129

 

--

To unsubscribe, e-mail: opensuse-security-announce+unsubscribe ( -at -) opensuse.org

For additional commands, e-mail: opensuse-security-announce+help ( -at -) opensuse.org

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×