Jump to content
Compatible Support Forums
Sign in to follow this  
mattmoooo

Linux Mandrake 9.2 - Starting after first install

Recommended Posts

Ok well i installed it and now im at the localhost login screen. Can anybody tell me how i start KDE or well any help at all would be good. I have no documentation i just know i installed 8.2 without a problem i liked it and so uninstalled that and windows and its at the login screen.

 

Please help i know im in the deep end but i figure theres such a big userbase for linux that this year is my year to learn

 

Thanks

/Matt

Share this post


Link to post
Share on other sites

ok well i got startx from the manual but now im stumped

ok more info after writing authority files it says

execve failed for /etc/X11/X (errno 2)

giving up

Xinit: No such file or directory

Xinit: No such process

back to where it began

/matt

Share this post


Link to post
Share on other sites

Congratulations! You posted all your messages on the same day and no one had the time to answer. You got it working, and now you know how you did it. There could be another newbie who may need your help. Welcome to the Linux club... 8)

Share this post


Link to post
Share on other sites

Same as Matmoo, I installed Mandrake 9.2.

For me this was on a Toshiba Laptop (490XCDT)

 

I am now currently looking at the KDE desktop. Looks great. But... what do I do next ?

I have the Mandrake 9.2. Refernece Guide here next to me, and it tells me to launch a terminal emulator, to start learning about the Command Line.

I'm supposed to look under Terminals in the KDE application menu... only problem is, nowhere in the KDE menu is there "Terminals".

 

Tnx in advance.

Share this post


Link to post
Share on other sites

Well call me Joe and slap me silly. laugh

 

I'm a bit embarrased of not seeing that wink

Thanks

 

 

But another question.

I never had to use Disc 2 & 3 during installation. Am I not supposed to use these ?

(I burned the ISO-images using Nero, as instructed on the Mandrake site)

Share this post


Link to post
Share on other sites

Don't be embarrased, you're in a whole new environment.

You know you can put an icon on your KDE desktop for quick access. Just right click on the desktop- create new- link to application. for "command" put konsole. name it "konsole" of course, and under "permissions" at the bottom, click on different user, and your user name. click on the icon to change it, otherwise you'll be stuck with a blue cog... wink

konsole is the default KDE terminal. You can copy to, and paste from it. Very handy when you need to show someone error messages. smile

Share this post


Link to post
Share on other sites

You probably used a small install choice. Disc 2 is a lot of 'extra' stuff, and disc 2 is 'international' stuff. Hang on to them in case you want more stuff... 8)

Share this post


Link to post
Share on other sites
Quote:
Ok well i installed it and now im at the localhost login screen. Can anybody tell me how i start KDE or well any help at all would be good. I have no documentation i just know i installed 8.2 without a problem i liked it and so uninstalled that and windows and its at the login screen.

Please help i know im in the deep end but i figure theres such a big userbase for linux that this year is my year to learn

Thanks
/Matt

Share this post


Link to post
Share on other sites

Greetings!

 

I am a total newbie to Linux and i'm trying to get used to it.

 

I'm getting the exact same errors.

 

How do i fix it?

 

thanks!

Share this post


Link to post
Share on other sites

So you have a black screen with login? Ok, try this. Type in your user name and enter, then password and enter. You should now be logged in. Now you will want to become root. Do that by typing:

 

su [enter]

 

When it asks, enter your password and press enter. The $ sign will now be a # sign. type:

 

kdm [enter]

 

The kdm user login screen should now come up. Try all this and tell me what happens. Good luck! smile

Share this post


Link to post
Share on other sites

ok i did what you said and it said the following:

 

xauth: creating new authority file /root/.Xauthority

xauth: creating new authority file /root/.Xauthority

Using authority file /root/.Xauthority

Writing authority file /root/.Xauthorty

Using authority file /root/.Xauthority

Writing authority file /root/.Xauthorty

execve failed for /etc/X11/X (errorno 2)

xinit: Server error.

 

What is going on here?

Share this post


Link to post
Share on other sites

Are you using Radeon? This sounds like a misconfigure problem with your video card. When you did the install, what did you enter when it asked about screen configuration etc.? As root type:

 

XFdrake [enter]

 

Try various settings in all the catagories. Start off at 640x480 resolution and work your way up. Try both versions of X. Also, and maybe most importantly, make sure you match your video card among all the choices given. You are not alone in having a difficult time with Mdk 9.1 or 9.2 finding screens, but take heart, this problem can be resolved.

Share this post


Link to post
Share on other sites

i had the same problem. using your tip, i went into XFdrake and played w/ the monitor and graphics card choice (fortunately the make was on the really old card)

Share this post


Link to post
Share on other sites

Originally posted by mattmoooo:

Quote:
ok well i got startx from the manual but now im stumped

ok more info after writing authority files it says

execve failed for /etc/X11/X (errno 2)

giving up

Xinit: No such file or directory

Xinit: No such process

back to where it began

/matt

 

Share this post


Link to post
Share on other sites

I suspect its a problem with your graphics card. I uesd to get the same problem (not starting X) and it got worse with some distros. Mandrake would run fine on 10 but not 100% on 10.1. Suse 9.1 and unbutu both failed to start X with various errors. I'm using suse 9.2 now and its fine. I have noticed how kernal changes can effect what was previously my distro of choice. You SHOULD NOT have to start X from the command line UNLESS you actually want to! If you are using the standard install options you should be in KDE right away at the KDE login screen. If you choose to auto login (as I do) you should be in KDE without typing anything. I suggest you try several of the LATEST distros on live CD's and when you find 1 that works with all your hardware (or at least with MOST of it) thats the 1 to actually install.

 

Regards, Pete

Share this post


Link to post
Share on other sites

A quick follow up to my previous post above. I just downloaded the new live cd KDE version of ubuntu (Kubuntu), burned it to a disk and booted from it. As I previuosly said the first live ubuntu cd i tried was not able to start X and I gave up on it. Hey!, the new version does actually start X ok and I was soon at the KDE desktop. On the suse 9.2 live cd i can from this point surf the web etc.by just opening a web browser, not so with ubuntu! Although it now works with my video chipset (on board VIA) it still does not recognise the network hardware and so cant find and use my ADSL router. So, as I said previously, ubuntu, which according to many is a fine distro, is of little use to me and there is no point actually installing it on this SYSTEM.

 

Regards, Pete

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×