Jump to content


Photo

[security-announce] SUSE-SU-2014:0967-1: important: Security update for the Apache Web Server


  • Please log in to reply
No replies to this topic

#1 News

News

    stranger

  • Members
  • 66205 posts

Posted 07 August 2014 - 01:07 AM

SUSE Security Update: Security update for the Apache Web Server
______________________________________________________________________________

Announcement ID: SUSE-SU-2014:0967-1
Rating: important
References: #859916 #869105 #869106 #887765 #887768
Cross-References: CVE-2013-6438 CVE-2014-0098 CVE-2014-0226
CVE-2014-0231
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
SUSE Linux Enterprise Server 11 SP3
______________________________________________________________________________

An update that solves four vulnerabilities and has one
errata is now available.

Description:


This update for the Apache Web Server provides the following fixes:

* Fixed a heap-based buffer overflow on apache module mod_status.
(bnc#887765, CVE-2014-0226)
* Properly remove whitespace characters from CDATA sections to avoid
remote denial of service by crashing the Apache Server process.
(bnc#869105, CVE-2013-6438)
* Correction to parsing of cookie content; this can lead to a crash
with a specially designed cookie sent to the server. (bnc#869106,
CVE-2014-0098)
* ECC support should not be missing. (bnc#859916)

This update also introduces a new configuration parameter
CGIDScriptTimeout, which defaults to the value of parameter Timeout.
CGIDScriptTimeout is set to 60s if mod_cgid is loaded/active, via
/etc/apache2/conf.d/cgid-timeout.conf. The new directive and its effect
prevent request workers to be eaten until starvation if cgi programs do
not send output back to the server within the timeout set by
CGIDScriptTimeout. (bnc#887768, CVE-2014-0231)

Security Issues references:

* CVE-2014-0226

* CVE-2013-6438

* CVE-2014-0098

* CVE-2014-0231



Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP3:

zypper in -t patch sdksp3-apache2-9542

- SUSE Linux Enterprise Server 11 SP3 for VMware:

zypper in -t patch slessp3-apache2-9542

- SUSE Linux Enterprise Server 11 SP3:

zypper in -t patch slessp3-apache2-9542

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP3 (i586 ia64 ppc64 s390x x86_64):

apache2-devel-2.2.12-1.46.1

- SUSE Linux Enterprise Software Development Kit 11 SP3 (i586 x86_64):

apache2-2.2.12-1.46.1
apache2-doc-2.2.12-1.46.1
apache2-example-pages-2.2.12-1.46.1
apache2-prefork-2.2.12-1.46.1
apache2-utils-2.2.12-1.46.1
apache2-worker-2.2.12-1.46.1

- SUSE Linux Enterprise Server 11 SP3 for VMware (i586 x86_64):

apache2-2.2.12-1.46.1
apache2-doc-2.2.12-1.46.1
apache2-example-pages-2.2.12-1.46.1
apache2-prefork-2.2.12-1.46.1
apache2-utils-2.2.12-1.46.1
apache2-worker-2.2.12-1.46.1

- SUSE Linux Enterprise Server 11 SP3 (i586 ia64 ppc64 s390x x86_64):

apache2-2.2.12-1.46.1
apache2-doc-2.2.12-1.46.1
apache2-example-pages-2.2.12-1.46.1
apache2-prefork-2.2.12-1.46.1
apache2-utils-2.2.12-1.46.1
apache2-worker-2.2.12-1.46.1


References:

http://support.novel...-2013-6438.html
http://support.novel...-2014-0098.html
http://support.novel...-2014-0226.html
http://support.novel...-2014-0231.html
https://bugzilla.novell.com/859916
https://bugzilla.novell.com/869105
https://bugzilla.novell.com/869106
https://bugzilla.novell.com/887765
https://bugzilla.novell.com/887768
http://download.suse...d6b37e956e1fda6

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe ( -at -) opensuse.org
For additional commands, e-mail: opensuse-security-announce+help ( -at -) opensuse.org







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

IPB Skin By Virteq